summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-25 21:53:37 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-25 21:53:37 +0000
commit1420439d8facc26e734ea53152b6ec32652850bd (patch)
treea1a69f18d0a54fe5a731a478b5e19a57a2630866 /net-mail/queue-fix
parentarm KEYWORDS (diff)
downloadhistorical-1420439d8facc26e734ea53152b6ec32652850bd.tar.gz
historical-1420439d8facc26e734ea53152b6ec32652850bd.tar.bz2
historical-1420439d8facc26e734ea53152b6ec32652850bd.zip
arm KEYWORDS
Diffstat (limited to 'net-mail/queue-fix')
-rw-r--r--net-mail/queue-fix/queue-fix-1.4-r2.ebuild31
1 files changed, 16 insertions, 15 deletions
diff --git a/net-mail/queue-fix/queue-fix-1.4-r2.ebuild b/net-mail/queue-fix/queue-fix-1.4-r2.ebuild
index bca2ab148574..e63ec8e6ca12 100644
--- a/net-mail/queue-fix/queue-fix-1.4-r2.ebuild
+++ b/net-mail/queue-fix/queue-fix-1.4-r2.ebuild
@@ -1,24 +1,26 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/queue-fix/queue-fix-1.4-r2.ebuild,v 1.8 2004/04/27 21:04:28 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/queue-fix/queue-fix-1.4-r2.ebuild,v 1.9 2004/05/25 21:53:37 vapier Exp $
-inherit eutils
+inherit eutils gcc
-S=${WORKDIR}/${P}
DESCRIPTION="Qmail Queue Repair Application with support for big-todo"
-SRC_URI="http://www.netmeridian.com/e-huss/${P}.tar.gz
- mirror://qmail/queue-fix-todo.patch"
HOMEPAGE="http://www.netmeridian.com/e-huss/"
+SRC_URI="http://www.netmeridian.com/e-huss/${P}.tar.gz
+ mirror://qmail/queue-fix-todo.patch"
-SLOT="0"
LICENSE="as-is"
-KEYWORDS="x86 alpha ~hppa mips ppc sparc amd64 ia64"
+SLOT="0"
+KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64"
IUSE=""
+
DEPEND="sys-devel/gcc-config"
-RDEPEND="|| ( net-mail/qmail
- net-mail/qmail-mysql
- net-mail/qmail-ldap
- )"
+RDEPEND="
+ || (
+ net-mail/qmail
+ net-mail/qmail-mysql
+ net-mail/qmail-ldap
+ )"
src_unpack() {
unpack ${P}.tar.gz
@@ -28,15 +30,14 @@ src_unpack() {
}
src_compile() {
- echo "${CC} ${CFLAGS}" > conf-cc
- echo "${CC} ${LDFLAGS}" > conf-ld
+ echo "$(gcc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(gcc-getCC) ${LDFLAGS}" > conf-ld
emake || die
}
src_install () {
into /var/qmail
- dobin queue-fix
+ dobin queue-fix || die
into /usr
dodoc README CHANGES
}
-