summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-11-12 19:37:27 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-11-12 19:37:27 +0000
commit6a10a164777f1770605d25100173353797aca24b (patch)
treeb01d5c2fc11e0932a2d1584ccbccf109625c9944 /sci-astronomy/celestia
parentMask media-sound/kstreamripper. (diff)
downloadhistorical-6a10a164777f1770605d25100173353797aca24b.tar.gz
historical-6a10a164777f1770605d25100173353797aca24b.tar.bz2
historical-6a10a164777f1770605d25100173353797aca24b.zip
Removed kde3 support, see bug #292845
Package-Manager: portage-2.2_rc48/cvs/Linux x86_64
Diffstat (limited to 'sci-astronomy/celestia')
-rw-r--r--sci-astronomy/celestia/ChangeLog6
-rw-r--r--sci-astronomy/celestia/celestia-1.5.1.ebuild57
-rw-r--r--sci-astronomy/celestia/celestia-1.6.0.ebuild36
3 files changed, 26 insertions, 73 deletions
diff --git a/sci-astronomy/celestia/ChangeLog b/sci-astronomy/celestia/ChangeLog
index 8bbab1c4d430..082a2892a0ed 100644
--- a/sci-astronomy/celestia/ChangeLog
+++ b/sci-astronomy/celestia/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-astronomy/celestia
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.54 2009/11/11 12:36:00 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.55 2009/11/12 19:37:27 bicatali Exp $
+
+ 12 Nov 2009; SĂ©bastien Fabbro <bicatali@gentoo.org>
+ celestia-1.5.1.ebuild, celestia-1.6.0.ebuild:
+ Removed kde3 support, see bug #292845
11 Nov 2009; Samuli Suominen <ssuominen@gentoo.org> celestia-1.5.1.ebuild,
celestia-1.6.0.ebuild:
diff --git a/sci-astronomy/celestia/celestia-1.5.1.ebuild b/sci-astronomy/celestia/celestia-1.5.1.ebuild
index 0e981f2be1f3..0a8b1fdf9fdc 100644
--- a/sci-astronomy/celestia/celestia-1.5.1.ebuild
+++ b/sci-astronomy/celestia/celestia-1.5.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.5.1.ebuild,v 1.12 2009/11/11 12:36:00 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.5.1.ebuild,v 1.13 2009/11/12 19:37:27 bicatali Exp $
-EAPI=1
-inherit eutils flag-o-matic gnome2 kde-functions autotools
+EAPI=2
+inherit eutils flag-o-matic gnome2 autotools
DESCRIPTION="OpenGL 3D space simulator"
HOMEPAGE="http://www.shatters.net/celestia/"
@@ -14,22 +14,18 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc ppc64 sparc x86"
-IUSE="cairo gnome gtk kde lua nls pch theora threads unicode"
+IUSE="cairo gnome gtk lua nls pch theora threads unicode"
RDEPEND="virtual/glu
media-libs/jpeg
media-libs/libpng
- gtk? ( !gnome? ( !kde? (
- >=x11-libs/gtk+-2.6
- >=x11-libs/gtkglext-1.0
- ) ) )
+ gtk? ( !gnome? ( >=x11-libs/gtk+-2.6 >=x11-libs/gtkglext-1.0 ) )
gnome? (
>=x11-libs/gtk+-2.6
>=x11-libs/gtkglext-1.0
>=gnome-base/libgnomeui-2.0
)
- kde? ( !gnome? ( kde-base/kdelibs:3.5 ) )
- !gtk? ( !gnome? ( !kde? ( virtual/glut ) ) )
+ !gtk? ( !gnome? ( virtual/glut ) )
lua? ( >=dev-lang/lua-5.0 )
cairo? ( x11-libs/cairo )
theora? ( media-libs/libtheora )"
@@ -39,31 +35,21 @@ DEPEND="${RDEPEND}
pkg_setup() {
# Check for one for the following use flags to be set.
-
- if ! use gnome && use kde; then
- einfo "USE=\"kde\" detected."
- CELESTIA_GUI="kde"
- elif ! use kde && use gnome; then
+ if use gnome; then
einfo "USE=\"gnome\" detected."
USE_DESTDIR="1"
CELESTIA_GUI="gnome"
- elif ! use kde && ! use gnome && use gtk; then
+ elif use gtk; then
einfo "USE=\"gtk\" detected."
CELESTIA_GUI="gtk"
- elif use kde && use gnome; then
- einfo "Both gnome and kde support requested. Defaulting to kde"
- CELESTIA_GUI="kde"
else
- ewarn "If you want to use the full gui, set USE=\"{kde/gnome/gtk}\""
+ ewarn "If you want to use the full gui, set USE=\"{gnome/gtk}\""
ewarn "Defaulting to glut support (no GUI)."
CELESTIA_GUI="glut"
fi
}
-src_unpack() {
-
- unpack ${A}
- cd "${S}"
+src_prepare() {
# make better desktop files
epatch "${FILESDIR}"/${PN}-1.5.0-desktop.patch
@@ -119,36 +105,19 @@ src_unpack() {
mv guide_ja.cel.utf8 guide_ja.cel
popd > /dev/null
fi
-
eautoreconf
-}
-
-src_compile() {
-
- if [[ ${CELESTIA_GUI} == kde ]]; then
- REALHOME="${HOME}"
- mkdir -p "${T}"/fakehome/.kde
- mkdir -p "${T}"/fakehome/.qt
- export HOME="${T}"/fakehome
- [[ -d ${REALHOME}/.ccache ]] && ln -sf "${REALHOME}/.ccache" "${HOME}/"
- set-kdedir 3
- export kde_widgetdir="${KDEDIR}/lib/kde3/plugins/designer"
- fi
-
filter-flags "-funroll-loops -frerun-loop-opt"
+}
+src_configure() {
econf \
--with-${CELESTIA_GUI} \
- --without-arts \
$(use_with lua) \
$(use_enable cairo) \
$(use_enable threads threading) \
$(use_enable nls) \
$(use_enable pch) \
- $(use_enable theora) \
- || die "econf failed"
-
- emake || die "emake failed"
+ $(use_enable theora)
}
src_install() {
diff --git a/sci-astronomy/celestia/celestia-1.6.0.ebuild b/sci-astronomy/celestia/celestia-1.6.0.ebuild
index f8c6668b6141..ce26831f8f83 100644
--- a/sci-astronomy/celestia/celestia-1.6.0.ebuild
+++ b/sci-astronomy/celestia/celestia-1.6.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.6.0.ebuild,v 1.4 2009/11/11 12:36:00 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.6.0.ebuild,v 1.5 2009/11/12 19:37:27 bicatali Exp $
EAPI=2
-inherit eutils flag-o-matic gnome2 kde-functions autotools
+inherit eutils flag-o-matic gnome2 autotools
DESCRIPTION="OpenGL 3D space simulator"
HOMEPAGE="http://www.shatters.net/celestia/"
@@ -12,23 +12,19 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="cairo gnome gtk kde nls pch theora threads"
+IUSE="cairo gnome gtk nls pch theora threads"
RDEPEND="virtual/glu
media-libs/jpeg
media-libs/libpng
>=dev-lang/lua-5.0
- gtk? ( !gnome? ( !kde? (
- >=x11-libs/gtk+-2.6
- >=x11-libs/gtkglext-1.0
- ) ) )
+ gtk? ( !gnome? ( >=x11-libs/gtk+-2.6 >=x11-libs/gtkglext-1.0 ) )
gnome? (
>=x11-libs/gtk+-2.6
>=x11-libs/gtkglext-1.0
>=gnome-base/libgnomeui-2.0
)
- kde? ( !gnome? ( kde-base/kdelibs:3.5 ) )
- !gtk? ( !gnome? ( !kde? ( virtual/glut ) ) )
+ !gtk? ( !gnome? ( virtual/glut ) )
cairo? ( x11-libs/cairo )
theora? ( media-libs/libtheora )"
@@ -37,21 +33,15 @@ DEPEND="${RDEPEND}
pkg_setup() {
# Check for one for the following use flags to be set.
- if ! use gnome && use kde; then
- einfo "USE=\"kde\" detected."
- CELESTIA_GUI="kde"
- elif ! use kde && use gnome; then
+ if use gnome; then
einfo "USE=\"gnome\" detected."
USE_DESTDIR="1"
CELESTIA_GUI="gnome"
- elif ! use kde && ! use gnome && use gtk; then
+ elif use gtk; then
einfo "USE=\"gtk\" detected."
CELESTIA_GUI="gtk"
- elif use kde && use gnome; then
- einfo "Both gnome and kde support requested. Defaulting to kde"
- CELESTIA_GUI="kde"
else
- ewarn "If you want to use the full gui, set USE=\"{kde|gnome|gtk}\""
+ ewarn "If you want to use the full gui, set USE=\"{gnome|gtk}\""
ewarn "Defaulting to glut support (no GUI)."
CELESTIA_GUI="glut"
fi
@@ -85,15 +75,6 @@ src_prepare() {
configure.in || die "sed failed"
fi
eautoreconf
- if [[ ${CELESTIA_GUI} == kde ]]; then
- REALHOME="${HOME}"
- mkdir -p "${T}"/fakehome/.kde
- mkdir -p "${T}"/fakehome/.qt
- export HOME="${T}"/fakehome
- [[ -d ${REALHOME}/.ccache ]] && ln -sf "${REALHOME}/.ccache" "${HOME}/"
- set-kdedir 3
- export kde_widgetdir="${KDEDIR}/lib/kde3/plugins/designer"
- fi
filter-flags "-funroll-loops -frerun-loop-opt"
}
@@ -103,7 +84,6 @@ src_configure() {
--disable-rpath \
--with-lua \
--with-${CELESTIA_GUI} \
- --without-arts \
$(use_enable cairo) \
$(use_enable threads threading) \
$(use_enable nls) \