summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2017-09-09 16:34:01 +0200
committerSebastian Pipping <sping@gentoo.org>2017-09-09 16:34:22 +0200
commit2a47a41754311f6d663f7ad97aae4507f6c8887d (patch)
treea34f861ae311b8dcb5156aaf2a2001a31cb7bcdf /dev-lang/python
parentAddress metadata.xml QA issues (bug 630158) (diff)
downloadblender-gentoo-logo-2a47a41754311f6d663f7ad97aae4507f6c8887d.tar.gz
blender-gentoo-logo-2a47a41754311f6d663f7ad97aae4507f6c8887d.tar.bz2
blender-gentoo-logo-2a47a41754311f6d663f7ad97aae4507f6c8887d.zip
dev-lang/python: No more cut(1) in global scope (bug 630158)
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/python-2.2-r8.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-lang/python/python-2.2-r8.ebuild b/dev-lang/python/python-2.2-r8.ebuild
index 27e8c93..6ea21fb 100644
--- a/dev-lang/python/python-2.2-r8.ebuild
+++ b/dev-lang/python/python-2.2-r8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/Attic/python-2.2-r7.ebuild,v 1.12 2003/04/01 00:05:24 liquidx dead $
@@ -6,10 +6,10 @@ EAPI="2"
MULTILIB_STRICT_DIRS= # Dirty hack to bypass failing multilib-strict testing
-inherit eutils flag-o-matic
+inherit versionator eutils flag-o-matic
-PYVER_MAJOR="`echo ${PV} | cut -d '.' -f 1`"
-PYVER_MINOR="`echo ${PV} | cut -d '.' -f 2`"
+PYVER_MAJOR="$(get_version_component_range 1)"
+PYVER_MINOR="$(get_version_component_range 2)"
PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
DESCRIPTION="A really great language"