aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGergely Nagy <ngg@ngg.hu>2019-10-20 15:53:47 +0200
committerGergely Nagy <ngg@ngg.hu>2019-10-20 15:55:53 +0200
commit818924806a080f323dd0e0a8f7922162397c27e6 (patch)
tree96581b0a35c8229c92c67419c96434b5976a0f70 /dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-2.1.3.ebuild
parentMerge pull request #441 from dargonforce/powershell (diff)
downloaddotnet-818924806a080f323dd0e0a8f7922162397c27e6.tar.gz
dotnet-818924806a080f323dd0e0a8f7922162397c27e6.tar.bz2
dotnet-818924806a080f323dd0e0a8f7922162397c27e6.zip
dev-dotnet/dotnetcore-sdk-bin: able to install multiple .NET Core SDK major versions
The dotnetcore-sdk-bin package now uses slots for different major versions. These can be installed parallel, the shared files between these are provided by the new dotnetcore-sdk-bin-common package. The non-slotted versions are removed to avoid confusion. Fixes: https://github.com/gentoo/dotnet/issues/433
Diffstat (limited to 'dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-2.1.3.ebuild')
-rw-r--r--dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-2.1.3.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-2.1.3.ebuild b/dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-2.1.3.ebuild
deleted file mode 100644
index 2f0a9f9..0000000
--- a/dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-2.1.3.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit eutils
-
-DESCRIPTION=".NET Core SDK - binary precompiled for glibc"
-HOMEPAGE="https://www.microsoft.com/net/core"
-LICENSE="MIT"
-
-SRC_URI="
-amd64? ( https://download.microsoft.com/download/2/9/3/293BC432-348C-4D1C-B628-5AC8AB7FA162/dotnet-sdk-${PV}-linux-x64.tar.gz -> dotnet-sdk-${PV}-linux-x64.tar.gz )
-"
-
-SLOT="0"
-KEYWORDS="~amd64"
-
-# The sdk includes the runtime-bin and aspnet-bin so prevent from installing at the same time
-# dotnetcore-sdk is the source based build
-
-RDEPEND="
- >=sys-apps/lsb-release-1.4
- >=sys-devel/llvm-4.0
- >=dev-util/lldb-4.0
- >=sys-libs/libunwind-1.1-r1
- >=dev-libs/icu-57.1
- >=dev-util/lttng-ust-2.8.1
- >=dev-libs/openssl-1.0.2h-r2
- >=net-misc/curl-7.49.0
- >=app-crypt/mit-krb5-1.14.2
- >=sys-libs/zlib-1.2.8-r1
- !dev-dotnet/dotnetcore-sdk
- !dev-dotnet/dotnetcore-runtime-bin
- !dev-dotnet/dotnetcore-aspnet-bin"
-
-S=${WORKDIR}
-
-src_install() {
- local dest="opt/dotnet_core"
- dodir "${dest}"
-
- local ddest="${D}${dest}"
- cp -a "${S}"/* "${ddest}/" || die
- dosym "/${dest}/dotnet" "/usr/bin/dotnet"
-}