aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGergely Nagy <ngg@ngg.hu>2021-03-03 22:11:32 +0100
committerGergely Nagy <ngg@ngg.hu>2021-03-03 22:11:32 +0100
commitd194761e24ce48031ea88b44600800fb2ab1b69a (patch)
tree77b63af36f7b43d5bcdbceabfe2555949a8caab7 /dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-5.0.103.ebuild
parentdev-dotnet/dotnetcore-sdk-bin{-common}: use another SRC_URI for easier upgrades (diff)
downloaddotnet-d194761e24ce48031ea88b44600800fb2ab1b69a.tar.gz
dotnet-d194761e24ce48031ea88b44600800fb2ab1b69a.tar.bz2
dotnet-d194761e24ce48031ea88b44600800fb2ab1b69a.zip
dev-dotnet/dotnetcore-sdk-bin{-common}: bump to 5.0.200
Signed-off-by: Gergely Nagy <ngg@ngg.hu>
Diffstat (limited to 'dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-5.0.103.ebuild')
-rw-r--r--dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-5.0.103.ebuild71
1 files changed, 0 insertions, 71 deletions
diff --git a/dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-5.0.103.ebuild b/dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-5.0.103.ebuild
deleted file mode 100644
index 67db935..0000000
--- a/dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-5.0.103.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit eutils
-
-MY_PV="${PV}"
-
-DESCRIPTION=".NET Core SDK - binary precompiled for glibc"
-HOMEPAGE="https://www.microsoft.com/net/core"
-LICENSE="MIT"
-
-SRC_URI="
-amd64? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-x64.tar.gz )
-arm? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-arm.tar.gz )
-arm64? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-arm64.tar.gz )
-"
-
-SLOT="5.0"
-KEYWORDS="~amd64"
-
-QA_PREBUILT="*"
-RESTRICT="splitdebug"
-
-# The sdk includes the runtime-bin and aspnet-bin so prevent from installing at the same time
-# dotnetcore-sdk is the source based build
-
-RDEPEND="
- >=dev-dotnet/dotnetcore-sdk-bin-common-${PV}
- >=sys-apps/lsb-release-1.4
- >=sys-devel/llvm-4.0
- >=dev-util/lldb-4.0
- >=sys-libs/libunwind-1.1-r1
- >=dev-libs/icu-57.1
- >=dev-util/lttng-ust-2.8.1
- || ( >=dev-libs/openssl-1.0.2h-r2 >=dev-libs/openssl-compat-1.0.2h-r2 )
- >=net-misc/curl-7.49.0
- >=app-crypt/mit-krb5-1.14.2
- >=sys-libs/zlib-1.2.8-r1
- !dev-dotnet/dotnetcore-sdk
- !dev-dotnet/dotnetcore-sdk-bin:0
- !dev-dotnet/dotnetcore-runtime-bin
- !dev-dotnet/dotnetcore-aspnet-bin"
-
-S=${WORKDIR}
-
-src_prepare() {
- default
-
- # For current .NET Core versions, all the directories contain versioned files,
- # but the top-level files (the dotnet binary for example) are shared between versions,
- # and those are backward-compatible.
- # The exception from this above rule is packs/NETStandard.Library.Ref which is shared between >=3.0 versions.
- # These common files are installed by the non-slotted dev-dotnet/dotnetcore-sdk-bin-common
- # package, while the directories are installed by dev-dotnet/dotnetcore-sdk-bin which uses
- # slots depending on major .NET Core version.
- # This makes it possible to install multiple major versions at the same time.
-
- # Skip the common files
- find . -maxdepth 1 -type f -exec rm -f {} \; || die
- rm -rf ./packs/NETStandard.Library.Ref || die
-}
-
-src_install() {
- local dest="opt/dotnet_core"
- dodir "${dest}"
-
- local ddest="${D}/${dest}"
- cp -a "${S}"/* "${ddest}/" || die
-}