summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2020-08-04 16:36:05 +0200
committerUlrich Müller <ulm@gentoo.org>2020-08-04 16:36:05 +0200
commit3db2539b8ce2daec01cb35730cbd057ff3c528e7 (patch)
tree75f3e10627b34393f916b7ed705c88d56b154cbd /app-editors/atto/atto-1.20_pre20180320.ebuild
parentelisp-common.eclass: Support installation of dynamic modules. (diff)
downloademacs-3db2539b8ce2daec01cb35730cbd057ff3c528e7.tar.gz
emacs-3db2539b8ce2daec01cb35730cbd057ff3c528e7.tar.bz2
emacs-3db2539b8ce2daec01cb35730cbd057ff3c528e7.zip
app-editors/atto: Initial import.
Ebuild contributed by me. Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-editors/atto/atto-1.20_pre20180320.ebuild')
-rw-r--r--app-editors/atto/atto-1.20_pre20180320.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-editors/atto/atto-1.20_pre20180320.ebuild b/app-editors/atto/atto-1.20_pre20180320.ebuild
new file mode 100644
index 0000000..655cdf2
--- /dev/null
+++ b/app-editors/atto/atto-1.20_pre20180320.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+COMMIT="1485816cc8e7556c634d2676b3ff17c3b998062a"
+DESCRIPTION="The smallest functional Emacs in less than 2000 lines of C"
+HOMEPAGE="https://github.com/hughbarney/atto"
+SRC_URI="https://github.com/hughbarney/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-libs/ncurses:0="
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LD="$(tc-getCC) ${LDFLAGS}" \
+ LIBS="$("$(tc-getPKG_CONFIG)" --libs ncursesw)"
+}
+
+src_install() {
+ dobin atto
+ dodoc README.md CHANGE.LOG.md docs/*.txt
+}