summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2011-08-17 15:25:31 +0000
committerUlrich Müller <ulm@gentoo.org>2011-08-17 15:25:31 +0000
commit8095df96b5019b338748e448882f46712781d280 (patch)
tree3b8e86e67ed1fe98ab63f8a016d0eceb195ef948 /app-editors/emacs-vcs/emacs-vcs-24.0.9999-r1.ebuild
parentSet last component of emacs-version to ${PR}+1. (diff)
downloademacs-8095df96b5019b338748e448882f46712781d280.tar.gz
emacs-8095df96b5019b338748e448882f46712781d280.tar.bz2
emacs-8095df96b5019b338748e448882f46712781d280.zip
Add an einfo message displaying the bzr revision.
svn path=/emacs-overlay/; revision=1673
Diffstat (limited to 'app-editors/emacs-vcs/emacs-vcs-24.0.9999-r1.ebuild')
-rw-r--r--app-editors/emacs-vcs/emacs-vcs-24.0.9999-r1.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/app-editors/emacs-vcs/emacs-vcs-24.0.9999-r1.ebuild b/app-editors/emacs-vcs/emacs-vcs-24.0.9999-r1.ebuild
index 6a57770..9b6bbf6 100644
--- a/app-editors/emacs-vcs/emacs-vcs-24.0.9999-r1.ebuild
+++ b/app-editors/emacs-vcs/emacs-vcs-24.0.9999-r1.ebuild
@@ -101,6 +101,7 @@ src_prepare() {
[ "${FULL_VERSION}" ] || die "Cannot determine current Emacs version"
echo
einfo "Emacs branch: ${EBZR_BRANCH}"
+ einfo "Revision: ${EBZR_REVISION:-${EBZR_REVNO}}"
einfo "Emacs version number: ${FULL_VERSION}"
[[ ${FULL_VERSION} =~ ^${PV%.*}(\..*)?$ ]] \
|| die "Upstream version number changed to ${FULL_VERSION}"
@@ -236,7 +237,7 @@ src_compile() {
# cleanup, otherwise emacs will be dumped again in src_install
(cd src; emake versionclean)
fi
- # hack: last component of emacs-version is ${PR}+1
+ # hack: set last component of emacs-version to ${PR}+1
touch src/emacs-${FULL_VERSION}.${PR#r}
emake CC="$(tc-getCC)"
}