summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2013-12-29 11:09:41 +0100
committerUlrich Müller <ulm@gentoo.org>2013-12-29 11:09:41 +0100
commit0e97c8f1b6ace6eea29703b409707186601c2467 (patch)
tree22f6e9d1e6738d46b789c65e97e3775b4a4e302b /app-editors/emacs-vcs/emacs-vcs-24.3.9999.ebuild
parentUpstream experimental version bump. Remove old. (diff)
downloademacs-0e97c8f1b6ace6eea29703b409707186601c2467.tar.gz
emacs-0e97c8f1b6ace6eea29703b409707186601c2467.tar.bz2
emacs-0e97c8f1b6ace6eea29703b409707186601c2467.zip
Merge changes from Portage tree.
Package-Manager: portage-2.2.7
Diffstat (limited to 'app-editors/emacs-vcs/emacs-vcs-24.3.9999.ebuild')
-rw-r--r--app-editors/emacs-vcs/emacs-vcs-24.3.9999.ebuild20
1 files changed, 9 insertions, 11 deletions
diff --git a/app-editors/emacs-vcs/emacs-vcs-24.3.9999.ebuild b/app-editors/emacs-vcs/emacs-vcs-24.3.9999.ebuild
index c3cdcc0..2d3a558 100644
--- a/app-editors/emacs-vcs/emacs-vcs-24.3.9999.ebuild
+++ b/app-editors/emacs-vcs/emacs-vcs-24.3.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-vcs/emacs-vcs-24.3.9999.ebuild,v 1.20 2013/08/31 22:13:48 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-vcs/emacs-vcs-24.3.9999.ebuild,v 1.21 2013/12/16 23:59:27 ulm Exp $
EAPI=5
@@ -116,15 +116,6 @@ src_prepare() {
fi
epatch_user
-
- if ! use gzip-el; then
- # Emacs' build system automatically detects the gzip binary and
- # compresses el files. We don't want that so confuse it with a
- # wrong binary name
- sed -i -e "/AC_PATH_PROG/s/gzip/PrEvEnTcOmPrEsSiOn/" configure.ac \
- || die "unable to sed configure.ac"
- fi
-
AT_M4DIR=m4 eautoreconf
}
@@ -215,7 +206,7 @@ src_configure() {
--infodir="${EPREFIX}"/usr/share/info/${EMACS_SUFFIX} \
--enable-locallisppath="${EPREFIX}/etc/emacs:${EPREFIX}${SITELISP}" \
--with-gameuser="${GAMES_USER_DED:-games}" \
- --without-compress-info \
+ --without-compress-install \
--with-file-notification=$(usev gfile || usev inotify || echo no) \
$(use_enable acl) \
$(use_with dbus) \
@@ -255,6 +246,13 @@ src_install () {
# remove unused <version>/site-lisp dir
rm -rf "${ED}"/usr/share/emacs/${FULL_VERSION}/site-lisp
+ if use gzip-el; then
+ # compress .el files when a corresponding .elc exists
+ find "${ED}"/usr/share/emacs/${FULL_VERSION}/lisp -type f \
+ -name "*.elc" -print | sed 's/\.elc$/.el/' | xargs gzip -9n
+ assert "gzip .el failed"
+ fi
+
local cdir
if use source; then
cdir="/usr/share/emacs/${FULL_VERSION}/src"