summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2014-03-16 17:51:58 +0100
committerUlrich Müller <ulm@gentoo.org>2014-03-16 17:51:58 +0100
commit3697931f9684d5fcafc6253b2450f55c13024daf (patch)
tree7388cbfe057827d67e54117ac0fce41ee38d6cda /app-editors/emacs/emacs-23.4-r6.ebuild
parentTrivial spelling fixes. (diff)
downloademacs-3697931f9684d5fcafc6253b2450f55c13024daf.tar.gz
emacs-3697931f9684d5fcafc6253b2450f55c13024daf.tar.bz2
emacs-3697931f9684d5fcafc6253b2450f55c13024daf.zip
Install emacs man page under the same name as the binary.
Package-Manager: portage-2.2.8-r1
Diffstat (limited to 'app-editors/emacs/emacs-23.4-r6.ebuild')
-rw-r--r--app-editors/emacs/emacs-23.4-r6.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/app-editors/emacs/emacs-23.4-r6.ebuild b/app-editors/emacs/emacs-23.4-r6.ebuild
index de19b4a..2ea9b5f 100644
--- a/app-editors/emacs/emacs-23.4-r6.ebuild
+++ b/app-editors/emacs/emacs-23.4-r6.ebuild
@@ -221,8 +221,11 @@ src_install () {
# move man pages to the correct place
local m
- for m in "${ED}"/usr/share/man/man1/* ; do
- mv "${m}" "${m%.1}-${EMACS_SUFFIX}.1" || die "mv man failed"
+ mv "${ED}"/usr/share/man/man1/{emacs,${EMACS_SUFFIX}}.1 \
+ || die "moving emacs man page failed"
+ for m in b2m ctags ebrowse emacsclient etags grep-changelog rcs-checkin; do
+ mv "${ED}"/usr/share/man/man1/${m}{,-${EMACS_SUFFIX}}.1 \
+ || die "moving ${m} man page failed"
done
# move info dir to avoid collisions with the dir file generated by portage
@@ -327,6 +330,9 @@ pkg_postinst() {
# force an update of the emacs symlink for the livecd/dvd,
# because some microemacs packages set it with USE=livecd
eselect emacs update
+ elif [[ $(readlink "${EROOT}"/usr/bin/emacs) = ${EMACS_SUFFIX} ]]; then
+ # refresh symlinks in case any installed files have changed
+ eselect emacs set ${EMACS_SUFFIX}
else
eselect emacs update ifunset
fi