summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-08-12 13:46:47 +0000
committerUlrich Müller <ulm@gentoo.org>2008-08-12 13:46:47 +0000
commit228c4c3f42297d0eec7e5ca885453e6d5449b92a (patch)
tree32956485c7d3a422edaaa31326bda5ca214fe26d /app-emacs/cedet
parentMask live ebuild for app-emacs/cedet. (diff)
downloademacs-228c4c3f42297d0eec7e5ca885453e6d5449b92a.tar.gz
emacs-228c4c3f42297d0eec7e5ca885453e6d5449b92a.tar.bz2
emacs-228c4c3f42297d0eec7e5ca885453e6d5449b92a.zip
Live CVS ebuild, bug 234536.
svn path=/emacs-overlay/; revision=1128
Diffstat (limited to 'app-emacs/cedet')
-rw-r--r--app-emacs/cedet/ChangeLog10
-rw-r--r--app-emacs/cedet/Manifest4
-rw-r--r--app-emacs/cedet/cedet-9999.ebuild73
-rw-r--r--app-emacs/cedet/files/60cedet-gentoo.el8
-rw-r--r--app-emacs/cedet/metadata.xml20
5 files changed, 115 insertions, 0 deletions
diff --git a/app-emacs/cedet/ChangeLog b/app-emacs/cedet/ChangeLog
new file mode 100644
index 0000000..de6b31d
--- /dev/null
+++ b/app-emacs/cedet/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-emacs/cedet
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*cedet-9999 (12 Aug 2008)
+
+ 12 Aug 2008; Ulrich Mueller <ulm@gentoo.org> +files/60cedet-gentoo.el,
+ +metadata.xml, +cedet-9999.ebuild:
+ Live CVS ebuild by Dmitry Dzhus <dima@sphinx.net.ru> in bug 234536.
+
diff --git a/app-emacs/cedet/Manifest b/app-emacs/cedet/Manifest
new file mode 100644
index 0000000..d1c5fd7
--- /dev/null
+++ b/app-emacs/cedet/Manifest
@@ -0,0 +1,4 @@
+AUX 60cedet-gentoo.el 269 RMD160 8772de35d81f0f8f3853bf17d9aee9787bd7d96a SHA1 549fcfafb1791a87e205516de76871aa179e00ec SHA256 d5cf0d7927b70bce54e45d837aac1e4131fe2d832fdfe7a352c695dcb374ad5b
+EBUILD cedet-9999.ebuild 1771 RMD160 86576833d21ef88ca0f3c9df264ec558e6f08413 SHA1 5a5f534586ec78bb37b7e6f134a87816722af1d9 SHA256 4e23a659655ac4c5bed106929b09aca4d580ec80df5bf5b82eefca4e914ace21
+MISC ChangeLog 324 RMD160 42bdf5ffd5f0e56536a35364a9ea4a196e9a66af SHA1 2d4313fe3b4a918d387f92b694bb95d0ca29ffc8 SHA256 547ae4f27293ff871de7fa180a73902b16ef3694a8ce53ca58c3e24e739631d1
+MISC metadata.xml 831 RMD160 742d588c9f37c4639acf627470e88e8da5c9e8c4 SHA1 315ec457e01f99f17211cf7229a17caec0ff3bf6 SHA256 3ef03457bb7af19d84fdd463e7a780ee79fa2812f5bd04fe5b15064d648b2999
diff --git a/app-emacs/cedet/cedet-9999.ebuild b/app-emacs/cedet/cedet-9999.ebuild
new file mode 100644
index 0000000..ad5482f
--- /dev/null
+++ b/app-emacs/cedet/cedet-9999.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+NEED_EMACS=22
+
+ECVS_SERVER="cedet.cvs.sourceforge.net:/cvsroot/cedet"
+ECVS_MODULE="cedet"
+ECVS_AUTH="pserver"
+ECVS_CVS_COMPRESS="-z3"
+ECVS_LOCALNAME="cedet"
+
+inherit eutils elisp cvs
+
+DESCRIPTION="CEDET: Collection of Emacs Development Tools"
+HOMEPAGE="http://cedet.sourceforge.net/"
+SRC_URI=""
+
+LICENSE="GPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="!app-emacs/semantic
+ !app-emacs/eieio
+ !app-emacs/speedbar"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${ECVS_LOCALNAME}"
+
+SITEFILE=60${PN}-gentoo.el
+
+src_compile() {
+ touch $(find . -name Makefile)
+ emake EMACS=/usr/bin/emacs || die "emake failed"
+}
+
+src_install() {
+ ecvs_clean
+ find "${S}" -type f -print | grep -v www | while read target; do
+ local directory=$(dirname ${target}) file=$(basename ${target})
+ local sub_directory=$(echo ${directory} | sed "s%^${S}/*%%;s/^$/./")
+ case $file in
+ *~ | Makefile* | *.texi | *-script | PRERELEASE_CHECKLIST \
+ | Project.ede | IMPLICIT_TARGETS | USING_CEDET_FROM_CVS)
+ ;;
+ ChangeLog | README | AUTHORS | *NEWS | INSTALL)
+ docinto ${sub_directory}
+ dodoc ${target}
+ ;;
+ # Only one file: grammar-fw-ov.png, referenced by grammar-fw.info
+ # Should be installed along with *.info or not at all
+ #*.png)
+ # insinto /usr/share/doc/${PF}/${sub_directory}
+ # doins ${target}
+ # ;;
+ *.el | *.elc)
+ insinto ${SITELISP}/${PN}/${sub_directory}
+ doins ${target}
+ ;;
+ *.info*)
+ doinfo ${target}
+ ;;
+ *)
+ insinto ${SITELISP}/${PN}/${sub_directory}
+ doins ${target}
+ echo ${target} >>"${S}/IMPLICIT_TARGETS"
+ ;;
+ esac
+ done
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}
diff --git a/app-emacs/cedet/files/60cedet-gentoo.el b/app-emacs/cedet/files/60cedet-gentoo.el
new file mode 100644
index 0000000..fb345e7
--- /dev/null
+++ b/app-emacs/cedet/files/60cedet-gentoo.el
@@ -0,0 +1,8 @@
+
+;;; cedet site-lisp configuration
+
+(load "@SITELISP@/common/cedet" nil t)
+
+;; If you wish to customize CEDET, you will need to follow the
+;; directions in the INSTALL (installed in the documentation) file and
+;; customize your ~/.emacs /before/ site-gentoo is loaded.
diff --git a/app-emacs/cedet/metadata.xml b/app-emacs/cedet/metadata.xml
new file mode 100644
index 0000000..bf7d92c
--- /dev/null
+++ b/app-emacs/cedet/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+ CEDET is a collection of tools written with the end goal of creating an
+ advanced development environment. Emacs already is a great environment for
+ writing software, but there are additional areas that need improvement.
+ Many new ideas for integrated environments have been developed in newer
+ products, such as Microsoft's Visual environment. CEDET is a new project
+ which brings together the various tools built to replicate these features.
+
+ Major Components of CEDET:
+ * SpeedBar
+ * EmacsLispObjects (EIEIO)
+ * SemanticBovinator
+ * ConnectedGraphEditor (COGRE)
+ * Makefile Generation and Project Management (EDE)
+</longdescription>
+</pkgmetadata>