summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2017-10-15 13:23:34 +0200
committerUlrich Müller <ulm@gentoo.org>2017-10-15 13:23:34 +0200
commit741958eae24083c4109038a32e37fbef39161dd3 (patch)
treeffb7c1f162c38c383f25e9f15d3f654022eeffe3 /app-emacs/emacs-daemon/emacs-daemon-9999.ebuild
parentapp-emacs/emacs-common-gentoo: Update EGIT_REPO_URI. (diff)
downloademacs-741958eae24083c4109038a32e37fbef39161dd3.tar.gz
emacs-741958eae24083c4109038a32e37fbef39161dd3.tar.bz2
emacs-741958eae24083c4109038a32e37fbef39161dd3.zip
app-emacs/emacs-daemon: Update EGIT_REPO_URI, sync from Gentoo repo.
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'app-emacs/emacs-daemon/emacs-daemon-9999.ebuild')
-rw-r--r--app-emacs/emacs-daemon/emacs-daemon-9999.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/app-emacs/emacs-daemon/emacs-daemon-9999.ebuild b/app-emacs/emacs-daemon/emacs-daemon-9999.ebuild
index b66542a..1f1045c 100644
--- a/app-emacs/emacs-daemon/emacs-daemon-9999.ebuild
+++ b/app-emacs/emacs-daemon/emacs-daemon-9999.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-EGIT_REPO_URI="git://anongit.gentoo.org/proj/emacs-tools.git"
+EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/emacs-tools.git"
EGIT_BRANCH="${PN}"
EGIT_CHECKOUT_DIR="${WORKDIR}/${PN}"
inherit elisp git-r3
DESCRIPTION="Gentoo support for Emacs running as a server in the background"
-HOMEPAGE="http://wiki.gentoo.org/wiki/Project:Emacs"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
LICENSE="GPL-2+"
SLOT="0"
@@ -28,18 +28,18 @@ pkg_setup() {
if [[ ${has_daemon} != t ]]; then
while read line; do ewarn "${line}"; done <<-EOF
- Your current Emacs version does not support running as a daemon
- which is required for ${CATEGORY}/${PN}.
+ Your current Emacs version does not support running as a daemon which
+ is required for ${CATEGORY}/${PN}.
Use "eselect emacs" to select an Emacs version >= 23.
EOF
elif [[ ${has_gtk} == t ]]; then
while read line; do ewarn "${line}"; done <<-EOF
- Your current Emacs is compiled with GTK+. There is a long-standing
- bug in GTK+ that prevents Emacs from recovering from X disconnects:
- <http://bugzilla.gnome.org/show_bug.cgi?id=85715>
- If you run Emacs as a daemon, then it is strongly recommended that
- you compile it with the Motif or the Lucid toolkit instead, i.e.
- with USE="motif -athena -gtk" or USE="athena -gtk -motif".
+ Your current Emacs is compiled with GTK+. There is a long-standing bug
+ in GTK+ that prevents Emacs from recovering from X disconnects:
+ <https://bugzilla.gnome.org/show_bug.cgi?id=85715>
+ If you run Emacs as a daemon, then it is strongly recommended that you
+ compile it with the Lucid or the Motif toolkit instead, i.e. with
+ USE="athena Xaw3d -gtk -motif" or USE="motif -gtk -athena -Xaw3d".
EOF
fi
}