summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-11-15 16:48:16 +0000
committerUlrich Müller <ulm@gentoo.org>2009-11-15 16:48:16 +0000
commit51a0340933a8d19f0e29f5cd1657caf8cb44179c (patch)
tree3c477f7d8f5ba28a0b21cbaa9a72c30189a87dc7 /app-emacs
parentFix typo. (diff)
downloademacs-51a0340933a8d19f0e29f5cd1657caf8cb44179c.tar.gz
emacs-51a0340933a8d19f0e29f5cd1657caf8cb44179c.tar.bz2
emacs-51a0340933a8d19f0e29f5cd1657caf8cb44179c.zip
Move live ebuild from Portage tree to emacs overlay.
svn path=/emacs-overlay/; revision=1469
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/gentoo-syntax/ChangeLog11
-rw-r--r--app-emacs/gentoo-syntax/Manifest4
-rw-r--r--app-emacs/gentoo-syntax/files/50gentoo-syntax-gentoo.el17
-rw-r--r--app-emacs/gentoo-syntax/gentoo-syntax-9999.ebuild39
-rw-r--r--app-emacs/gentoo-syntax/metadata.xml5
5 files changed, 76 insertions, 0 deletions
diff --git a/app-emacs/gentoo-syntax/ChangeLog b/app-emacs/gentoo-syntax/ChangeLog
new file mode 100644
index 0000000..385cf70
--- /dev/null
+++ b/app-emacs/gentoo-syntax/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/gentoo-syntax
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*gentoo-syntax-9999 (15 Nov 2009)
+
+ 15 Nov 2009; Ulrich Mueller <ulm@gentoo.org>
+ +files/50gentoo-syntax-gentoo.el, +gentoo-syntax-9999.ebuild,
+ +metadata.xml:
+ Move live ebuild from Portage tree to emacs overlay.
+
diff --git a/app-emacs/gentoo-syntax/Manifest b/app-emacs/gentoo-syntax/Manifest
new file mode 100644
index 0000000..1dde2dd
--- /dev/null
+++ b/app-emacs/gentoo-syntax/Manifest
@@ -0,0 +1,4 @@
+AUX 50gentoo-syntax-gentoo.el 775 RMD160 1bb4b888f91f36c8c04d48cde03812d33358340e SHA1 6d2c06af487dae3bca560a7e8ff72d7ee5d8b804 SHA256 8ee075b11b745567d2ddd4b1c6eef30e43de8bf5a5b28a812ffae0123d0a2009
+EBUILD gentoo-syntax-9999.ebuild 1011 RMD160 66398a4e74d9d946b99dd99ce3e9bd23d639fdc0 SHA1 96accee8be45da8612d99f42434159ae87ca670b SHA256 b72f47966ae3e74b97e7de656cadee76ea53af6cec476ddb4263ca89d7bd99d9
+MISC ChangeLog 343 RMD160 1cfc2503bfefd7c90741174f9b5ae20c222b9943 SHA1 551b901c5e1d10c3c91e71cded26c1f53e34f883 SHA256 6a7829b7ce26fb77c85dfda32c23ac449cdc5a6980d1bbcf09db1fdd6b43f4d8
+MISC metadata.xml 158 RMD160 415d172437ca754d24fc5ab186ba8e77934d96e4 SHA1 61f6eff9729cd87a725c2a70c81aca4270a17fc4 SHA256 1393bdef3a74343fdb40a112c7096a1af16f67e7a43413250de28dfe73810eab
diff --git a/app-emacs/gentoo-syntax/files/50gentoo-syntax-gentoo.el b/app-emacs/gentoo-syntax/files/50gentoo-syntax-gentoo.el
new file mode 100644
index 0000000..82eb56e
--- /dev/null
+++ b/app-emacs/gentoo-syntax/files/50gentoo-syntax-gentoo.el
@@ -0,0 +1,17 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'ebuild-mode "gentoo-syntax"
+ "Major mode for Portage .ebuild and .eclass files." t)
+(autoload 'eselect-mode "gentoo-syntax" "Major mode for .eselect files." t)
+(autoload 'gentoo-newsitem-mode "gentoo-syntax"
+ "Major mode for Gentoo GLEP 42 news items." t)
+
+(add-to-list 'auto-mode-alist
+ '("\\.\\(ebuild\\|eclass\\|eblit\\)\\'" . ebuild-mode))
+(add-to-list 'auto-mode-alist '("\\.eselect\\'" . eselect-mode))
+(add-to-list 'auto-mode-alist
+ '("/[0-9]\\{4\\}-[01][0-9]-[0-3][0-9]-.+\\.[a-z]\\{2\\}\\.txt\\'"
+ . gentoo-newsitem-mode))
+(add-to-list 'interpreter-mode-alist '("runscript" . sh-mode))
+(modify-coding-system-alist 'file "\\.\\(ebuild\\|eclass\\)\\'" 'utf-8)
+
+(setq ebuild-mode-portdir "@PORTDIR@")
diff --git a/app-emacs/gentoo-syntax/gentoo-syntax-9999.ebuild b/app-emacs/gentoo-syntax/gentoo-syntax-9999.ebuild
new file mode 100644
index 0000000..5f3328e
--- /dev/null
+++ b/app-emacs/gentoo-syntax/gentoo-syntax-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit elisp subversion
+
+ESVN_REPO_URI="svn://anonsvn.gentoo.org/emacs/${PN}"
+DESCRIPTION="Emacs modes for editing ebuilds and other Gentoo specific files"
+HOMEPAGE="http://www.gentoo.org/proj/en/lisp/emacs/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+DOCS="ChangeLog"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ makeinfo gentoo-syntax.texi || die
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc || die
+ sed -e "s:@PORTDIR@:${PORTDIR}:" \
+ "${FILESDIR}/${SITEFILE}" >"${T}/${SITEFILE}" || die
+ elisp-site-file-install "${T}/${SITEFILE}" || die
+ doinfo gentoo-syntax.info || die
+ dodoc ${DOCS} || die
+}
+
+pkg_postinst() {
+ elisp-site-regen
+
+ elog "Some optional features may require installation of additional"
+ elog "packages, like app-portage/gentoolkit-dev for echangelog."
+}
diff --git a/app-emacs/gentoo-syntax/metadata.xml b/app-emacs/gentoo-syntax/metadata.xml
new file mode 100644
index 0000000..bc306fe
--- /dev/null
+++ b/app-emacs/gentoo-syntax/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>