summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2011-12-03 08:21:32 +0000
committerUlrich Müller <ulm@gentoo.org>2011-12-03 08:21:32 +0000
commit782b1fc66a537370a26cc4765b664318968973da (patch)
treebb11a3d1361e9cce99e5a1c251f2225b13d3b256 /app-emacs
parentMask org-mode live ebuild. (diff)
downloademacs-782b1fc66a537370a26cc4765b664318968973da.tar.gz
emacs-782b1fc66a537370a26cc4765b664318968973da.tar.bz2
emacs-782b1fc66a537370a26cc4765b664318968973da.zip
Live ebuild, bug 392303.
svn path=/emacs-overlay/; revision=1758
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/org-mode/ChangeLog10
-rw-r--r--app-emacs/org-mode/files/50org-mode-gentoo.el3
-rw-r--r--app-emacs/org-mode/metadata.xml23
-rw-r--r--app-emacs/org-mode/org-mode-9999.ebuild74
4 files changed, 110 insertions, 0 deletions
diff --git a/app-emacs/org-mode/ChangeLog b/app-emacs/org-mode/ChangeLog
new file mode 100644
index 0000000..b4eb34c
--- /dev/null
+++ b/app-emacs/org-mode/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-emacs/org-mode
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*org-mode-9999 (03 Dec 2011)
+
+ 03 Dec 2011; Ulrich Mueller <ulm@gentoo.org> +files/50org-mode-gentoo.el,
+ +org-mode-9999.ebuild, +metadata.xml:
+ Live ebuild, bug 392303. Thanks to Tom Prince <tom.prince@ualberta.net>.
+
diff --git a/app-emacs/org-mode/files/50org-mode-gentoo.el b/app-emacs/org-mode/files/50org-mode-gentoo.el
new file mode 100644
index 0000000..447ecbb
--- /dev/null
+++ b/app-emacs/org-mode/files/50org-mode-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(add-to-list 'auto-mode-alist '("\\.org\\'" . org-mode))
+(require 'org-install)
diff --git a/app-emacs/org-mode/metadata.xml b/app-emacs/org-mode/metadata.xml
new file mode 100644
index 0000000..9c6bc29
--- /dev/null
+++ b/app-emacs/org-mode/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+ Org-mode is a mode for keeping notes, maintaining ToDo lists, and doing
+ project planning with a fast and effective plain-text system.
+
+ Org-mode develops organizational tasks around NOTES files that contain
+ information about projects as plain text. Org-mode is implemented on top of
+ outline-mode, which makes it possible to keep the content of large files
+ well structured. Visibility cycling and structure editing help to work with
+ the tree. Tables are easily created with a built-in table editor. Org-mode
+ supports ToDo items, deadlines, time stamps, and scheduling. It dynamically
+ compiles entries into an agenda. Plain text URL-like links connect to
+ websites, emails, Usenet messages, BBDB entries, and any files related to
+ the projects. For printing and sharing of notes, an Org-mode file can be
+ exported as a structured ASCII file, HTML, and LaTeX.
+</longdescription>
+<use>
+ <flag name='contrib'>Install user-contributed files</flag>
+</use>
+</pkgmetadata>
diff --git a/app-emacs/org-mode/org-mode-9999.ebuild b/app-emacs/org-mode/org-mode-9999.ebuild
new file mode 100644
index 0000000..9b64277
--- /dev/null
+++ b/app-emacs/org-mode/org-mode-9999.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+NEED_EMACS=22
+
+inherit elisp
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="git://orgmode.org/org-mode.git"
+ inherit git-2
+else
+ SRC_URI="http://orgmode.org/org-${PV}.tar.gz"
+fi
+
+DESCRIPTION="An Emacs mode for notes and project planning"
+HOMEPAGE="http://www.orgmode.org/"
+
+LICENSE="GPL-3 FDL-1.3 contrib? ( GPL-2 MIT as-is )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~x86-macos"
+IUSE="contrib"
+
+DEPEND=""
+RDEPEND=""
+if [[ ${PV} = 9999 ]]; then
+ # additional build time dependencies for perl and TeX
+ DEPEND="${DEPEND}
+ dev-lang/perl
+ virtual/tex-base
+ virtual/texi2dvi"
+fi
+
+S="${WORKDIR}/org-${PV}"
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ # Remove autoload file to make sure that it is regenerated with
+ # the right Emacs version.
+ rm -f lisp/org-install.el
+}
+
+src_compile() {
+ emake
+ if [[ ${PV} = 9999 ]]; then
+ emake info pdf card
+ fi
+}
+
+src_install() {
+ emake \
+ prefix="${ED}/usr" \
+ lispdir="${ED}${SITELISP}/${PN}" \
+ infodir="${ED}/usr/share/info" \
+ install
+
+ cp "${FILESDIR}/${SITEFILE}" "${T}/${SITEFILE}"
+
+ if use contrib; then
+ elisp-install ${PN}/contrib contrib/lisp/*org*.el || die
+ insinto /usr/share/doc/${PF}/contrib
+ doins -r contrib/README contrib/babel contrib/odt contrib/scripts
+ find "${ED}/usr/share/doc/${PF}/contrib" -type f -name '.*' \
+ -exec rm -f '{}' '+'
+ # add the contrib subdirectory to load-path
+ sed -ie 's:\(.*@SITELISP@\)\(.*\):&\n\1/contrib\2:' \
+ "${T}/${SITEFILE}" || die
+ fi
+
+ elisp-site-file-install "${T}/${SITEFILE}" || die
+ doinfo doc/org
+ dodoc README doc/orgcard.txt doc/org.pdf doc/orgcard.pdf doc/orgguide.pdf
+}