summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2013-06-26 23:00:55 +0200
committerUlrich Müller <ulm@gentoo.org>2013-06-26 23:00:55 +0200
commit782ce918980a1bcdb12ec07e067d44a3fb5177a6 (patch)
tree7c6c4a51b7e4019a4fb4632136474842395324c2 /app-emacs
parentMerge changes from emacs-vcs. (diff)
downloademacs-782ce918980a1bcdb12ec07e067d44a3fb5177a6.tar.gz
emacs-782ce918980a1bcdb12ec07e067d44a3fb5177a6.tar.bz2
emacs-782ce918980a1bcdb12ec07e067d44a3fb5177a6.zip
Initial import. Ebuild contributed by <yakor.spb@gmail.com>, with modifications by me. Bug 463584.
Package-Manager: portage-2.1.12.10
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/multiple-cursors/ChangeLog11
-rw-r--r--app-emacs/multiple-cursors/Manifest1
-rw-r--r--app-emacs/multiple-cursors/files/50multiple-cursors-gentoo.el2
-rw-r--r--app-emacs/multiple-cursors/metadata.xml5
-rw-r--r--app-emacs/multiple-cursors/multiple-cursors-1.2.1.ebuild24
5 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/multiple-cursors/ChangeLog b/app-emacs/multiple-cursors/ChangeLog
new file mode 100644
index 0000000..20f9c70
--- /dev/null
+++ b/app-emacs/multiple-cursors/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/multiple-cursors
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*multiple-cursors-1.2.1 (26 Jun 2013)
+
+ 26 Jun 2013; Ulrich Müller <ulm@gentoo.org> +multiple-cursors-1.2.1.ebuild,
+ +files/50multiple-cursors-gentoo.el, +metadata.xml:
+ Initial import. Ebuild contributed by <yakor.spb@gmail.com>, with
+ modifications by me. Bug 463584.
+
diff --git a/app-emacs/multiple-cursors/Manifest b/app-emacs/multiple-cursors/Manifest
new file mode 100644
index 0000000..924a652
--- /dev/null
+++ b/app-emacs/multiple-cursors/Manifest
@@ -0,0 +1 @@
+DIST multiple-cursors-1.2.1.tar.gz 51229 SHA256 c83d015ce4a64780f74d855b980cf851603c5fd9fc2141c436693eed90d24750 SHA512 855b6b4c01bd5bc7aad07587d967478f1b4ed0a21aad950a36f25057667f53a5994c26f63cbfcb7e0e053699375a034da35ec437efcf0906b62a80fd4dd1da90 WHIRLPOOL f654903630df82137411fbaa47fab71d388a1402ee197c7297a5939503ba95f55053cd4103ba22d295e2b2d02a3d2dc63b20e9cfbe61202e3645c5cc3c546147
diff --git a/app-emacs/multiple-cursors/files/50multiple-cursors-gentoo.el b/app-emacs/multiple-cursors/files/50multiple-cursors-gentoo.el
new file mode 100644
index 0000000..c0c0d4c
--- /dev/null
+++ b/app-emacs/multiple-cursors/files/50multiple-cursors-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(require 'multiple-cursors-autoloads)
diff --git a/app-emacs/multiple-cursors/metadata.xml b/app-emacs/multiple-cursors/metadata.xml
new file mode 100644
index 0000000..bc306fe
--- /dev/null
+++ b/app-emacs/multiple-cursors/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>
diff --git a/app-emacs/multiple-cursors/multiple-cursors-1.2.1.ebuild b/app-emacs/multiple-cursors/multiple-cursors-1.2.1.ebuild
new file mode 100644
index 0000000..6e123ce
--- /dev/null
+++ b/app-emacs/multiple-cursors/multiple-cursors-1.2.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Multiple cursors for Emacs"
+HOMEPAGE="https://github.com/magnars/multiple-cursors.el"
+SRC_URI="https://github.com/magnars/${PN}.el/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${PN}.el-${PV}"
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README.md"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}