summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emacs/emacs-common/emacs-common-9999.ebuild24
-rw-r--r--app-emacs/emacs-common/metadata.xml8
2 files changed, 23 insertions, 9 deletions
diff --git a/app-emacs/emacs-common/emacs-common-9999.ebuild b/app-emacs/emacs-common/emacs-common-9999.ebuild
index bb0b926..61306a4 100644
--- a/app-emacs/emacs-common/emacs-common-9999.ebuild
+++ b/app-emacs/emacs-common/emacs-common-9999.ebuild
@@ -1,27 +1,28 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/emacs-tools.git"
EGIT_BRANCH="${PN}"
EGIT_CHECKOUT_DIR="${WORKDIR}/${PN}"
-inherit elisp-common desktop xdg-utils readme.gentoo-r1 git-r3
+inherit elisp-common desktop gnome2-utils xdg-utils readme.gentoo-r1 git-r3
DESCRIPTION="Common files needed by all GNU Emacs versions"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
+S="${WORKDIR}/${PN}"
LICENSE="GPL-3+"
SLOT="0"
-IUSE="games gui"
+IUSE="games gsettings gui"
-RDEPEND="games? ( acct-group/gamestat )"
-DEPEND="${RDEPEND}"
+DEPEND="games? ( acct-group/gamestat )"
+RDEPEND="!=app-editors/emacs-29.1_rc1-r0
+ ${DEPEND}
+ gui? ( gsettings? ( dev-libs/glib ) )"
PDEPEND=">=app-editors/emacs-23.1:*"
-S="${WORKDIR}/${PN}"
-
src_install() {
insinto "${SITELISP}"
sed -e "s:@libdir@:$(get_libdir):g" subdirs.el.in | newins - subdirs.el
@@ -53,6 +54,11 @@ src_install() {
doicon -s scalable emacs23.svg
newicon -s scalable emacs25.svg emacs.svg
popd
+
+ if use gsettings; then
+ insinto /usr/share/glib-2.0/schemas
+ doins org.gnu.emacs.defaults.gschema.xml
+ fi
fi
DOC_CONTENTS="All site initialisation for Gentoo-installed packages is
@@ -95,6 +101,7 @@ pkg_postinst() {
if use gui; then
xdg_desktop_database_update
xdg_icon_cache_update
+ use gsettings && gnome2_schemas_update
fi
readme.gentoo_print_elog
}
@@ -103,5 +110,6 @@ pkg_postrm() {
if use gui; then
xdg_desktop_database_update
xdg_icon_cache_update
+ use gsettings && gnome2_schemas_update
fi
}
diff --git a/app-emacs/emacs-common/metadata.xml b/app-emacs/emacs-common/metadata.xml
index 57ea14e..8c804e6 100644
--- a/app-emacs/emacs-common/metadata.xml
+++ b/app-emacs/emacs-common/metadata.xml
@@ -5,7 +5,13 @@
<email>gnu-emacs@gentoo.org</email>
<name>Gentoo GNU Emacs project</name>
</maintainer>
+<stabilize-allarches/>
<use>
- <flag name='games'>Support shared score files for games</flag>
+ <flag name="games">Support shared score files for games</flag>
+ <flag name="gsettings">Install schema file for gsettings
+ (<pkg>dev-libs/glib</pkg>)</flag>
</use>
+<upstream>
+ <remote-id type="gentoo">proj/emacs-tools</remote-id>
+</upstream>
</pkgmetadata>