summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emacs/ebuild-mode/ebuild-mode-9999.ebuild18
1 files changed, 12 insertions, 6 deletions
diff --git a/app-emacs/ebuild-mode/ebuild-mode-9999.ebuild b/app-emacs/ebuild-mode/ebuild-mode-9999.ebuild
index 283609e..1bec4c2 100644
--- a/app-emacs/ebuild-mode/ebuild-mode-9999.ebuild
+++ b/app-emacs/ebuild-mode/ebuild-mode-9999.ebuild
@@ -1,25 +1,31 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/ebuild-mode.git"
EGIT_BRANCH="master"
EGIT_CHECKOUT_DIR="${WORKDIR}/${PN}"
-inherit elisp git-r3 readme.gentoo-r1
+inherit elisp git-r3 optfeature
DESCRIPTION="Emacs modes for editing ebuilds and other Gentoo specific files"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
+S="${WORKDIR}/${PN}"
LICENSE="GPL-2+"
SLOT="0"
BDEPEND="sys-apps/texinfo"
-S="${WORKDIR}/${PN}"
DOCS="ChangeLog keyword-generation.sh"
ELISP_TEXINFO="${PN}.texi"
SITEFILE="50${PN}-gentoo.el"
-DOC_CONTENTS="Some optional features may require installation of additional
- packages, like dev-python/docutils-glep for glep."
+
+pkg_postinst() {
+ elisp_pkg_postinst
+ optfeature "ebuild commands support" sys-apps/portage
+ optfeature "additional development tools" dev-util/pkgdev
+ optfeature "ebuild QA utilities" dev-util/pkgcheck
+ optfeature "generating HTML from GLEPs" dev-python/docutils-glep
+}