summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/pemacs/pemacs-9999.ebuild')
-rw-r--r--app-editors/pemacs/pemacs-9999.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/app-editors/pemacs/pemacs-9999.ebuild b/app-editors/pemacs/pemacs-9999.ebuild
deleted file mode 100644
index b1d3db2..0000000
--- a/app-editors/pemacs/pemacs-9999.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit toolchain-funcs
-
-if [[ ${PV} = 9999 ]]; then
- EGIT_REPO_URI="https://github.com/hughbarney/pEmacs.git"
- EGIT_CHECKOUT_DIR="${WORKDIR}/${PN}"
- inherit git-r3
-else
- # snapshot from git repo
- SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
-fi
-
-DESCRIPTION="Perfect Emacs, a small footprint Emacs derived from Ersatz Emacs"
-HOMEPAGE="https://github.com/hughbarney/pEmacs"
-
-LICENSE="public-domain"
-SLOT="0"
-
-RDEPEND="sys-libs/ncurses:0="
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-S="${WORKDIR}/${PN}"
-
-src_compile() {
- emake CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS} -Wall" \
- LFLAGS="${LDFLAGS} $("$(tc-getPKG_CONFIG)" --libs ncurses)"
-}
-
-src_install() {
- dobin pe
- doman pe.1
- dodoc README.md
-}