summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/emacs-common-gentoo/emacs-common-gentoo-9999.ebuild')
-rw-r--r--app-emacs/emacs-common-gentoo/emacs-common-gentoo-9999.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/app-emacs/emacs-common-gentoo/emacs-common-gentoo-9999.ebuild b/app-emacs/emacs-common-gentoo/emacs-common-gentoo-9999.ebuild
index 9f0d73e..4bd5cd9 100644
--- a/app-emacs/emacs-common-gentoo/emacs-common-gentoo-9999.ebuild
+++ b/app-emacs/emacs-common-gentoo/emacs-common-gentoo-9999.ebuild
@@ -75,11 +75,11 @@ src_install() {
pkg_preinst() {
# make sure that site-gentoo.el exists since site-start.el requires it
- if [[ ! -d ${EROOT}${SITELISP} ]]; then
+ if [[ ! -f ${ED}${SITELISP}/site-gentoo.el ]]; then #554518
mv "${ED}${SITELISP}"/site-gentoo.el{.orig,} || die
- else
+ fi
+ if [[ -d ${EROOT}${SITELISP} ]]; then
elisp-site-regen
- rm "${ED}${SITELISP}/site-gentoo.el.orig" || die
cp "${EROOT}${SITELISP}/site-gentoo.el" "${ED}${SITELISP}/" || die
fi