aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2016-05-01 14:39:23 -0700
committerBrian Dolbec <dolsen@gentoo.org>2016-05-01 14:39:23 -0700
commitfbd57fc21ca4e391d5ad2b19cc32603d9474bb68 (patch)
treee380daa105430774c798ef7b23befcff4ce91862 /eclass-test
parentEbuild invalid pkg (diff)
downloadgen-b0rk-fbd57fc21ca4e391d5ad2b19cc32603d9474bb68.tar.gz
gen-b0rk-fbd57fc21ca4e391d5ad2b19cc32603d9474bb68.tar.bz2
gen-b0rk-fbd57fc21ca4e391d5ad2b19cc32603d9474bb68.zip
eclass-test/live-keywords: Test live ebuilds keywords use
Diffstat (limited to 'eclass-test')
-rw-r--r--eclass-test/live-keywords/live-keywords-8888.ebuild20
-rw-r--r--eclass-test/live-keywords/live-keywords-9999.ebuild19
-rw-r--r--eclass-test/live-keywords/metadata.xml26
3 files changed, 65 insertions, 0 deletions
diff --git a/eclass-test/live-keywords/live-keywords-8888.ebuild b/eclass-test/live-keywords/live-keywords-8888.ebuild
new file mode 100644
index 0000000..f35dac6
--- /dev/null
+++ b/eclass-test/live-keywords/live-keywords-8888.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGIT_REPO="http://foo.com/repos/foo-bard.git"
+EGIT_BRANCH="foo-bar"
+
+inherit xfconf git-r3
+
+DESCRIPTION="Test ebuild for live VCS check"
+HOMEPAGE="http://foo.com"
+SRC_URI=""
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~mips ~ppc ~ppc64 x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="debug"
+
diff --git a/eclass-test/live-keywords/live-keywords-9999.ebuild b/eclass-test/live-keywords/live-keywords-9999.ebuild
new file mode 100644
index 0000000..0ccc985
--- /dev/null
+++ b/eclass-test/live-keywords/live-keywords-9999.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGIT_REPO="http://foo.com/repos/foo-bard.git"
+EGIT_BRANCH="foo-bar"
+
+inherit xfconf git-r3
+
+DESCRIPTION="Test ebuild for live VCS check"
+HOMEPAGE="http://foo.com"
+SRC_URI=""
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="debug"
diff --git a/eclass-test/live-keywords/metadata.xml b/eclass-test/live-keywords/metadata.xml
new file mode 100644
index 0000000..4c1b972
--- /dev/null
+++ b/eclass-test/live-keywords/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!--
+# $Id$
+
+This is the example metadata file.
+The root element of this file is <pkgmetadata>. Within this element a
+number of subelements are allowed, the most common being maintainer.
+
+For a full description look at:
+https://devmanual.gentoo.org/ebuild-writing/misc-files/metadata/
+
+Before committing, please remove the comments from this file. They are
+not relevant for general metadata.xml files.
+-->
+<pkgmetadata>
+<maintainer type="person">
+ <email>exampledev@gentoo.org</email>
+ <description>Primary maintainer</description>
+</maintainer>
+<maintainer type="project">
+ <email>exampleproject@gentoo.org</email>
+ <name>Gentoo Example Project</name>
+</maintainer>
+<longdescription>Test for the LiveEclassChecks keywords check</longdescription>
+</pkgmetadata>