aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2020-06-30 08:09:36 +0200
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2020-06-30 08:09:36 +0200
commita6db29b2b5ce35274322c6c9c1b4e6a0de1d710d (patch)
tree2ff34e8986b8e1e7e8f1560e9c06b914935e5b3e
parentdev-python/dataclasses: Remove, package is in ::gentoo. (diff)
downloadguru-a6db29b2b5ce35274322c6c9c1b4e6a0de1d710d.tar.gz
guru-a6db29b2b5ce35274322c6c9c1b4e6a0de1d710d.tar.bz2
guru-a6db29b2b5ce35274322c6c9c1b4e6a0de1d710d.zip
dev-python/websockets: Remove, package is in ::gentoo.
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
-rw-r--r--dev-python/websockets/Manifest2
-rw-r--r--dev-python/websockets/metadata.xml35
-rw-r--r--dev-python/websockets/websockets-7.0.ebuild31
-rw-r--r--dev-python/websockets/websockets-8.1.ebuild32
4 files changed, 0 insertions, 100 deletions
diff --git a/dev-python/websockets/Manifest b/dev-python/websockets/Manifest
deleted file mode 100644
index 5c779d1d4..000000000
--- a/dev-python/websockets/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST websockets-7.0.tar.gz 122848 BLAKE2B 7c201831c563a8ae036f9310533a3627fca9e9f91ba77cac27a62852336d4c2a79bd07b3186e10e0c797520a73750201e3ca70358fe5a0304b35e9f6b637196c SHA512 08dd310d8f946522f60ba302f3246f81e283d11f308f658a3c3a3c597281a31b1376e5d16d900187d148b0c1ec1250cd730ccb26f6b753dd86ca5682a08af9a9
-DIST websockets-8.1.tar.gz 156472 BLAKE2B 6cb5eec8276f7ef7172048eba6157560f42cec28acacc1a0a2f426ea1cab9a04029ebb1f8285b1aa2862c30aac8f2af81ef85d4dba8e53e267b665b718e01d5a SHA512 d245702574cf513da54bfc0ca10768558cd4e5017ecf8cb647f4b9176561192a3ace64edfc5c6f735664bf1b6136aa0bb9828114478f92d2c051e3109a218c12
diff --git a/dev-python/websockets/metadata.xml b/dev-python/websockets/metadata.xml
deleted file mode 100644
index 5839cf456..000000000
--- a/dev-python/websockets/metadata.xml
+++ /dev/null
@@ -1,35 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-
-<pkgmetadata>
- <maintainer type="person">
- <email>andrewammerlaan@riseup.net</email>
- <name>Andrew Ammerlaan</name>
- </maintainer>
- <longdescription lang="en">
-What is websockets?
-
-websockets is a library for building WebSocket servers and clients in Python with a focus on correctness and simplicity.
-
-Built on top of asyncio, Python's standard asynchronous I/O framework, it provides an elegant coroutine-based API.
-Why should I use websockets?
-
-The development of websockets is shaped by four principles:
-
- Simplicity: all you need to understand is msg = await ws.recv() and await ws.send(msg); websockets takes care of managing connections so you can focus on your application.
- Robustness: websockets is built for production; for example it was the only library to handle backpressure correctly before the issue became widely known in the Python community.
- Quality: websockets is heavily tested. Continuous integration fails under 100% branch coverage. Also it passes the industry-standard Autobahn Testsuite.
- Performance: memory use is configurable. An extension written in C accelerates expensive operations. It's pre-compiled for Linux, macOS and Windows and packaged in the wheel format for each system and Python version.
-
-Documentation is a first class concern in the project. Head over to Read the Docs and see for yourself.
-Why shouldn't I use websockets?
-
- If you prefer callbacks over coroutines: websockets was created to provide the best coroutine-based API to manage WebSocket connections in Python. Pick another library for a callback-based API.
- If you're looking for a mixed HTTP / WebSocket library: websockets aims at being an excellent implementation of RFC 6455: The WebSocket Protocol and RFC 7692: Compression Extensions for WebSocket. Its support for HTTP is minimal — just enough for a HTTP health check.
- If you want to use Python 2: websockets builds upon asyncio which only works on Python 3. websockets requires Python ≥ 3.6.1.
- </longdescription>
- <upstream>
- <remote-id type="github">aaugustin/websockets</remote-id>
- <remote-id type="pypi">websockets</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/websockets/websockets-7.0.ebuild b/dev-python/websockets/websockets-7.0.ebuild
deleted file mode 100644
index ee9fcd1b0..000000000
--- a/dev-python/websockets/websockets-7.0.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="An implementation of the WebSocket Protocol (RFC 6455 & 7692)"
-HOMEPAGE="
- https://github.com/aaugustin/websockets
- https://pypi.org/project/websockets
-"
-SRC_URI="https://github.com/aaugustin/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-python_prepare_all() {
- # these tests fail, probably because of
- # a permission error (no internet)
- rm tests/test_client_server.py || die
- rm tests/test_protocol.py || die
-
- distutils-r1_python_prepare_all
-}
-
-distutils_enable_tests nose
-distutils_enable_sphinx docs dev-python/sphinx-autodoc-typehints dev-python/sphinxcontrib-spelling dev-python/sphinxcontrib-trio
diff --git a/dev-python/websockets/websockets-8.1.ebuild b/dev-python/websockets/websockets-8.1.ebuild
deleted file mode 100644
index 9307bdd1b..000000000
--- a/dev-python/websockets/websockets-8.1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="An implementation of the WebSocket Protocol (RFC 6455 & 7692)"
-HOMEPAGE="
- https://github.com/aaugustin/websockets
- https://pypi.org/project/websockets/
-"
-SRC_URI="https://github.com/aaugustin/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-python_prepare_all() {
- # these tests fail, probably because of
- # a permission error (no internet)
- rm tests/test_client_server.py || die
- rm tests/test_protocol.py || die
- rm tests/test_auth.py || die
-
- distutils-r1_python_prepare_all
-}
-
-distutils_enable_tests nose
-distutils_enable_sphinx docs dev-python/sphinx-autodoc-typehints dev-python/sphinxcontrib-spelling dev-python/sphinxcontrib-trio