aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-05-29 12:02:31 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-05-29 12:56:42 +0500
commitef17ed456dbd3892e2d82766ee0d95ad4cc7a12e (patch)
tree1945ce0baeb9fc13b39d58e68845cb13346342e0
parentdev-cpp/xtensor: update xsimd version (diff)
downloadguru-ef17ed456dbd3892e2d82766ee0d95ad4cc7a12e.tar.gz
guru-ef17ed456dbd3892e2d82766ee0d95ad4cc7a12e.tar.bz2
guru-ef17ed456dbd3892e2d82766ee0d95ad4cc7a12e.zip
www-apps/castopod: new package, add 1.3.5
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
-rw-r--r--www-apps/castopod/Manifest1
-rw-r--r--www-apps/castopod/castopod-1.3.5.ebuild40
-rw-r--r--www-apps/castopod/metadata.xml8
3 files changed, 49 insertions, 0 deletions
diff --git a/www-apps/castopod/Manifest b/www-apps/castopod/Manifest
new file mode 100644
index 000000000..8ac95380b
--- /dev/null
+++ b/www-apps/castopod/Manifest
@@ -0,0 +1 @@
+DIST castopod-1.3.5.tar.gz 52956999 BLAKE2B 3cb72dcd18c5334969eadbbd2979967d4299c69e922f389f1f6689e9ce12ca7cb4d5e4ea0faaeeac7e6dc1d15dd4b63f8d348cbe8c3d9cb938d018f6b8abf697 SHA512 a9e702265edb9377958bed1d4694b04b1c76d0472c1a80e9af92f38058b24f511da364f2c9870e3be22bea3ed9292eb7c0607a98d3022b1229f316c76351a3dd
diff --git a/www-apps/castopod/castopod-1.3.5.ebuild b/www-apps/castopod/castopod-1.3.5.ebuild
new file mode 100644
index 000000000..15fe9e37d
--- /dev/null
+++ b/www-apps/castopod/castopod-1.3.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature webapp
+
+UPLOAD_HASH="0071d5055a69176c706591649b1d725d"
+DESCRIPTION="Open-source hosting platform made for podcasters"
+HOMEPAGE="
+ https://castopod.org
+ https://code.castopod.org/adaures/castopod
+"
+SRC_URI="https://code.castopod.org/adaures/${P}/uploads/${UPLOAD_HASH}/${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="AGPL-3+ Apache-2.0 BSD-2 BSD GPL-1+ GPL-2 GPL-2+ GPL-3 LGPL-3 MIT MPL-2.0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-lang/php-8.1[curl,exif,gd,intl,mysqli,unicode,webp,xml]
+ virtual/httpd-php
+"
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/writable
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ optfeature "better cache perfomance" dev-db/redis
+ optfeature "video clips support" media-video/ffmpeg
+}
diff --git a/www-apps/castopod/metadata.xml b/www-apps/castopod/metadata.xml
new file mode 100644
index 000000000..7ebbd0334
--- /dev/null
+++ b/www-apps/castopod/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>cyber+gentoo@sysrq.in</email>
+ <name>Anna</name>
+ </maintainer>
+</pkgmetadata>