aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Reva <denis7774@gmail.com>2023-03-05 16:46:44 +0500
committerDenis Reva <denis7774@gmail.com>2023-03-05 18:01:50 +0500
commitc18016e57189dc526a7d6a70f550605c5193e0f4 (patch)
treee8606b1ed8125917639f9e50d94e1afce52fd79b /app-arch
parentgames-misc/gay: add 1.2.9 (diff)
downloadguru-c18016e57189dc526a7d6a70f550605c5193e0f4.tar.gz
guru-c18016e57189dc526a7d6a70f550605c5193e0f4.tar.bz2
guru-c18016e57189dc526a7d6a70f550605c5193e0f4.zip
app-arch/zarchive: new package
I don't know is it dev-lib/ or app-arch/ category I think app-arch/ Signed-off-by: Denis Reva <denis7774@gmail.com>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/zarchive/Manifest1
-rw-r--r--app-arch/zarchive/metadata.xml24
-rw-r--r--app-arch/zarchive/zarchive-0.1.2.ebuild20
3 files changed, 45 insertions, 0 deletions
diff --git a/app-arch/zarchive/Manifest b/app-arch/zarchive/Manifest
new file mode 100644
index 000000000..b72a6e91e
--- /dev/null
+++ b/app-arch/zarchive/Manifest
@@ -0,0 +1 @@
+DIST zarchive-0.1.2.tar.gz 19779 BLAKE2B 1dc985d442b6758638022f5d4e42d225d47632f11c4d2a231589e84eee82ddd2ef8d45073c84ae7c08aab6619b41ff3b1a6961fadc7a2fe755d04b0693646568 SHA512 b9666e8e86e5162b4ee641905a288088311d5cd1af510b2fbf22eba722ad2d8ca43a081b14c0106743807eff256bac9a0cacbdeb06e8ccad0e8d5b9ed8fa886e
diff --git a/app-arch/zarchive/metadata.xml b/app-arch/zarchive/metadata.xml
new file mode 100644
index 000000000..a2a4b7118
--- /dev/null
+++ b/app-arch/zarchive/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'http://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>denis7774@gmail.com</email>
+ <name>Denis Reva</name>
+ <description>rarogcmex</description>
+ </maintainer>
+ <longdescription lang="en">
+ ZArchive is yet another file archive format. Think of zip, tar, 7z, etc. but with the requirement of allowing random-access reads and supporting compression.
+
+ - Supports random-access reads within stored files
+ - Uses zstd compression (64KiB blocks)
+ - Scales reasonably well up to multiple terabytes with millions of files
+ - The theoretical size limit per-file is 2^48-1 (256 Terabyte)
+ - The encoding for paths within the archive is Windows-1252 (case-insensitive)
+ - Contains a SHA256 hash of the whole archive for integrity checks
+ - Endian-independent. The format always uses big-endian internally
+ - Stateless file and directory iterator handles which don't require memory allocation
+ </longdescription>
+ <upstream>
+ <remote-id type="github">Exzap/ZArchive</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-arch/zarchive/zarchive-0.1.2.ebuild b/app-arch/zarchive/zarchive-0.1.2.ebuild
new file mode 100644
index 000000000..533dc13a7
--- /dev/null
+++ b/app-arch/zarchive/zarchive-0.1.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Library for creating and reading zstd-compressed file archives (.zar)"
+HOMEPAGE="https://github.com/Exzap/ZArchive"
+SRC_URI="https://github.com/Exzap/ZArchive/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="app-arch/zstd"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-util/cmake"
+
+S="${WORKDIR}/ZArchive-${PV}"