aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenri Gasc <gasc@eurecom.fr>2023-04-15 21:20:52 +0200
committerHenri Gasc <gasc@eurecom.fr>2023-04-15 21:41:05 +0200
commit1a9c0b53a56114d9e273f20fdb1d6ed1bc420c38 (patch)
treefe21ece380934af18c871013d42c28de01fbebe5 /app-editors
parentapp-office/nixnote-bin add 2.1.8 (diff)
downloadguru-1a9c0b53a56114d9e273f20fdb1d6ed1bc420c38.tar.gz
guru-1a9c0b53a56114d9e273f20fdb1d6ed1bc420c38.tar.bz2
guru-1a9c0b53a56114d9e273f20fdb1d6ed1bc420c38.zip
app-editors/imhex: add 1.28.0, drop 1.26.2-r1
Closes: https://bugs.gentoo.org/869221 Closes: https://bugs.gentoo.org/887225 Closes: https://bugs.gentoo.org/890395 Closes: https://bugs.gentoo.org/890397 Closes: https://bugs.gentoo.org/890403 Closes: https://bugs.gentoo.org/890405 Signed-off-by: Henri Gasc <gasc@eurecom.fr>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/imhex/Manifest4
-rw-r--r--app-editors/imhex/imhex-1.28.0.ebuild (renamed from app-editors/imhex/imhex-1.26.2-r1.ebuild)40
-rw-r--r--app-editors/imhex/metadata.xml5
3 files changed, 19 insertions, 30 deletions
diff --git a/app-editors/imhex/Manifest b/app-editors/imhex/Manifest
index cbda9d18a..df3ae9a46 100644
--- a/app-editors/imhex/Manifest
+++ b/app-editors/imhex/Manifest
@@ -1,2 +1,2 @@
-DIST imhex-1.26.2.tar.gz 24320937 BLAKE2B d9d084729b460873476e8ed1df916cef3c502775dac5010f4ff12ea859ec750b417f09155be8b030cb74d8db95be83e46251144533e4ca5008ab0f26f7ab775d SHA512 cb913105903b8288c0d7fa7f8afb9567dd278d7088787823d27c0cc19a345d8ce9f5880341151dd0940580ff526658476ae86b0002084891df4062afd9b38a00
-DIST imhex-patterns-1.26.2.tar.gz 6846014 BLAKE2B c84d8242d5ef574799cdf8919948d5590b47f18a7c097dbd380ba76ca47ed836470b64a600d1fd4352b0e34d631d9d2ce732c44006484c7198dfffdf55b0c850 SHA512 828d03bbd0d765ca646f91e5f2df3efade1cdf68db0ddf42d7973c83011807b1c5d75bfc1609ba431b31811373483611b9ea72a129644af6df19143428943e30
+DIST imhex-1.28.0.tar.gz 25806823 BLAKE2B c75bfcb3badbf3d7e5c42356b977e931a82cebc8e42795f364f0eadc5fa9e47074e87e09f3d118e2b59d35c900b1d690cc6f8c3ab20b4f888a9137c9b9aca45e SHA512 28a509b477c5185020111c08174e310fb40c00069b7ec94c992118e02436cb5a5e98be6d8b73e223de36bd9bc9232e47d209b85bfa37c800da8940e1875c517d
+DIST imhex-patterns-1.28.0.tar.gz 3065487 BLAKE2B 98fac9ca010a3c91feb7a4c4455d8957f2786dfa349ab08a7c3cb4fd238f98d2debc59ab9034cf9aae934ef3302311d64d2c78913e2d8c7ecc9f4c709da125a2 SHA512 3d3b3157ea54773d6520bd9dd399c36e57436fe789bafecede4a1b4084e82cbf961d5c96a334febdca56466a8991c5cc2527c4bccee34cc848fd0f2a029ff311
diff --git a/app-editors/imhex/imhex-1.26.2-r1.ebuild b/app-editors/imhex/imhex-1.28.0.ebuild
index 3297637f4..47e614e30 100644
--- a/app-editors/imhex/imhex-1.26.2-r1.ebuild
+++ b/app-editors/imhex/imhex-1.28.0.ebuild
@@ -6,12 +6,12 @@ EAPI=8
CMAKE_BUILD_TYPE="Release"
CMAKE_MAKEFILE_GENERATOR="emake"
-inherit cmake desktop llvm toolchain-funcs xdg
+inherit cmake llvm toolchain-funcs
DESCRIPTION="A hex editor for reverse engineers, programmers, and eyesight"
HOMEPAGE="https://github.com/WerWolv/ImHex"
SRC_URI="
- https://github.com/WerWolv/ImHex/releases/download/v${PV}/Full.Sources.tar.gz -> ${P}.tar.gz
+ https://github.com/WerWolv/ImHex/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
https://github.com/WerWolv/ImHex-Patterns/archive/refs/tags/ImHex-v${PV}.tar.gz -> ${PN}-patterns-${PV}.tar.gz
"
S="${WORKDIR}/ImHex"
@@ -25,6 +25,7 @@ DEPEND="
app-forensics/yara
>=dev-cpp/nlohmann_json-3.10.2
dev-libs/capstone
+ dev-libs/nativefiledialog-extended
>=dev-libs/libfmt-8.0.0:=
media-libs/freetype
media-libs/glfw
@@ -74,15 +75,21 @@ src_configure() {
-D CMAKE_OBJCXX_COMPILER_LAUNCHER=ccache \
-D CMAKE_SKIP_RPATH=ON \
-D IMHEX_USE_BUNDLED_CA=OFF \
- -D IMHEX_IGNORE_BAD_CLONE=ON \
- -D IMHEX_OFFLINE_BUILD=ON \
+ -D IMHEX_PLUGINS_IN_SHARE=OFF \
-D IMHEX_STRIP_RELEASE=OFF \
+ -D IMHEX_OFFLINE_BUILD=ON \
+ -D IMHEX_IGNORE_BAD_CLONE=ON \
+ -D IMHEX_PATTERNS_PULL_MASTER=OFF \
+ -D IMHEX_IGNORE_BAD_COMPILER=OFF \
+ -D IMHEX_USE_GTK_FILE_PICKER=OFF \
+ -D IMHEX_DISABLE_STACKTRACE=OFF \
-D IMHEX_VERSION="${PV}" \
-D PROJECT_VERSION="${PV}" \
-D USE_SYSTEM_CAPSTONE=ON \
-D USE_SYSTEM_CURL=ON \
-D USE_SYSTEM_FMT=ON \
-D USE_SYSTEM_LLVM=ON \
+ -D USE_SYSTEM_NFD=ON \
-D USE_SYSTEM_NLOHMANN_JSON=ON \
-D USE_SYSTEM_YARA=ON
)
@@ -98,31 +105,10 @@ src_test() {
}
src_install() {
- # Can't use cmake_src_install, doing it manual
- # Executable
- dobin "${BUILD_DIR}/${PN}"
- chrpath -d "${ED}/usr/bin/${PN}" || die
- # Shared lib and plugins
- dolib.so "${BUILD_DIR}"/lib/lib"${PN}"/lib"${PN}".so*
- chrpath -d "${ED}"/usr/"$(get_libdir)"/lib"${PN}".so* || die
- exeinto "/usr/$(get_libdir)/${PN}/plugins"
- for plugin in builtin; do
- doexe "${BUILD_DIR}/plugins/${plugin}.hexplug"
- chrpath -d "${ED}/usr/$(get_libdir)/${PN}/plugins/${plugin}.hexplug" || die
- done
- # Desktop and icon files
- domenu "${S}/dist/${PN}.desktop"
- newicon -s scalable "${S}/resources/icon.svg" "${PN}.svg"
- for i in 16 22 24 32 36 48 64 72 96 128 192 256 512; do
- mkdir "${T}/${i}x${i}" || die
- rsvg-convert -a -f png -w "${i}" -o "${T}/${i}x${i}/${PN}.png" "${S}/resources/icon.svg" || die
- doicon -s "${i}" "${T}/${i}x${i}/${PN}.png"
- done
-
- # Install docs
- einstalldocs
+ cmake_src_install
# Install patterns
insinto /usr/share/imhex
+ rm -rf "${S_PATTERNS}/tests"
doins -r "${S_PATTERNS}"/*
}
diff --git a/app-editors/imhex/metadata.xml b/app-editors/imhex/metadata.xml
index 6816a6f59..51ae86832 100644
--- a/app-editors/imhex/metadata.xml
+++ b/app-editors/imhex/metadata.xml
@@ -1,7 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer needed -->
+ <maintainer type="person">
+ <email>gasc@eurecom.fr</email>
+ <name>Gasc Henri</name>
+ </maintainer>
<upstream>
<changelog>https://github.com/WerWolv/ImHex/releases</changelog>
<bugs-to>https://github.com/WerWolv/ImHex/issues</bugs-to>