aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-09-08 11:57:12 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-09-08 11:57:12 +0200
commite222151ca67455b2fa34d257fd2f67c7e49041da (patch)
tree93e5f93b3c430c41ecbe91bce439742920d66303 /app-editors
parentapp-editors/helix: drop old (BadFilename) (diff)
downloadguru-e222151ca67455b2fa34d257fd2f67c7e49041da.tar.gz
guru-e222151ca67455b2fa34d257fd2f67c7e49041da.tar.bz2
guru-e222151ca67455b2fa34d257fd2f67c7e49041da.zip
app-editors/helix: quote S/WORKDIR variables
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/helix/helix-22.05.ebuild6
-rw-r--r--app-editors/helix/helix-22.08.1.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/app-editors/helix/helix-22.05.ebuild b/app-editors/helix/helix-22.05.ebuild
index 13add4792..470d94a4d 100644
--- a/app-editors/helix/helix-22.05.ebuild
+++ b/app-editors/helix/helix-22.05.ebuild
@@ -269,8 +269,8 @@ src_prepare() {
for line in "${LANGUAGES[@]}"; do
read -r name url commit <<< "${line}"
- mkdir -p ${S}/runtime/grammars/sources/${name} || die
- cp -r ${WORKDIR}/${url##*/}-${commit}/* ${S}/runtime/grammars/sources/${name} || die
+ mkdir -p "${S}/runtime/grammars/sources/${name}" || die
+ cp -r "${WORKDIR}"/${url##*/}-${commit}/* "${S}/runtime/grammars/sources/${name}" || die
done
fi
@@ -285,7 +285,7 @@ src_compile() {
}
src_install() {
- use grammar && ( rm -rf ${S}/runtime/grammars/sources || die )
+ use grammar && ( rm -rf "${S}/runtime/grammars/sources" || die )
insinto /usr/share/helix
doins -r runtime
use doc && dodoc README.md CHANGELOG.md
diff --git a/app-editors/helix/helix-22.08.1.ebuild b/app-editors/helix/helix-22.08.1.ebuild
index f6fc157e4..949ac41c2 100644
--- a/app-editors/helix/helix-22.08.1.ebuild
+++ b/app-editors/helix/helix-22.08.1.ebuild
@@ -301,8 +301,8 @@ src_prepare() {
for line in "${LANGUAGES[@]}"; do
read -r name url commit <<< "${line}"
- mkdir -p ${S}/runtime/grammars/sources/${name} || die
- cp -r ${WORKDIR}/${url##*/}-${commit}/* ${S}/runtime/grammars/sources/${name} || die
+ mkdir -p "${S}/runtime/grammars/sources/${name}" || die
+ cp -r "${WORKDIR}"/${url##*/}-${commit}/* "${S}/runtime/grammars/sources/${name}" || die
done
fi
@@ -317,7 +317,7 @@ src_compile() {
}
src_install() {
- use grammar && ( rm -rf ${S}/runtime/grammars/sources || die )
+ use grammar && ( rm -rf "${S}/runtime/grammars/sources" || die )
insinto /usr/share/helix
doins -r runtime
use doc && dodoc README.md CHANGELOG.md