aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-07-23 10:22:21 +0200
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-07-23 11:00:47 +0200
commite6ef07f418eefea3dd62ac584fdd9654a149b52f (patch)
tree86c06724dcd7ca59478ba2eb14dfc57da3f6bc71 /dev-cpp/coeurl
parentsys-apps/asus-touchpad-numpad-driver: initial import (diff)
downloadguru-e6ef07f418eefea3dd62ac584fdd9654a149b52f.tar.gz
guru-e6ef07f418eefea3dd62ac584fdd9654a149b52f.tar.bz2
guru-e6ef07f418eefea3dd62ac584fdd9654a149b52f.zip
dev-cpp/coeurl: add 0.2.1, update SLOT, add ssl USE-flag
The ABI is now stable for a matching major.minor version: <https://nheko.im/nheko-reborn/coeurl/-/tags/v0.2.1>. Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
Diffstat (limited to 'dev-cpp/coeurl')
-rw-r--r--dev-cpp/coeurl/Manifest1
-rw-r--r--dev-cpp/coeurl/coeurl-0.2.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-cpp/coeurl/Manifest b/dev-cpp/coeurl/Manifest
index 7b8e81763..9bd17bdbc 100644
--- a/dev-cpp/coeurl/Manifest
+++ b/dev-cpp/coeurl/Manifest
@@ -1,2 +1,3 @@
DIST coeurl-0.1.1.tar.bz2 45471 BLAKE2B ea5b490cb62ed780c4499d15c1f9502185f8edab9d706cc422eda62d9149512e693e82fa9431a05c58e2bb949314a9de0d513d54824a07c1e4ca6bc801065189 SHA512 9f781b30f57314253602b8560954122537b3c1d40cc327c62aac3662ba80ec8fe45fc69adec5c571b8861c996724c7869e4dc88fafc5ebee31794299de999e34
DIST coeurl-0.2.0.tar.bz2 45520 BLAKE2B 8a26f43817af213971c6c8d568251f3306857d9fa8ebdd09aa0a1f548c31b00fe1431334ff546ab152edd002f56d23d006240c494ad2ccaf9292afff97583a84 SHA512 de5f405b6993a33cf958996430d0f7a25cccb47488c3c2ce44525630e533a5acd1d630e2293cdae74befc627de81b211b4a9b6d53138f3de1d92f267f016e4fb
+DIST coeurl-0.2.1.tar.bz2 45784 BLAKE2B e1280478d6112171e387d88f10ef220ac839e9be3b222c60111f0e046b00161f29561fce5bc62cc806bd0188fa2ad64f54d016e04e53af9032e69b6cc8dd4153 SHA512 0e65c1120eb352d75976a2b1f11a83dea4e6557276b22962c37e6387bf649ad18117f6f4b4b1b76d4cce2ef53d55834aacf7207e7c15e015344f3c4a60a49671
diff --git a/dev-cpp/coeurl/coeurl-0.2.1.ebuild b/dev-cpp/coeurl/coeurl-0.2.1.ebuild
new file mode 100644
index 000000000..ee74c33a2
--- /dev/null
+++ b/dev-cpp/coeurl/coeurl-0.2.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="A simple async wrapper around CURL for C++"
+HOMEPAGE="https://nheko.im/nheko-reborn/coeurl"
+SRC_URI="https://nheko.im/nheko-reborn/coeurl/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
+S="${WORKDIR}/${PN}-v${PV}"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+IUSE="ssl test"
+RESTRICT="test" # Tests turned off because they need a local webserver.
+
+RDEPEND="
+ net-misc/curl[ssl?]
+ dev-libs/libevent
+ dev-libs/libfmt:=
+ dev-libs/spdlog
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-cpp/doctest )
+"
+
+src_configure() {
+ local -a emesonargs=(
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}