aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-26 17:58:12 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-26 18:35:07 +0200
commit7b5b7a5652d0d637c1538474374a24c2480fe347 (patch)
treef8c830a6657fe5cef3fe6cf10892657bc34c784f /dev-cpp/fizz
parentdev-python/transaction: test in the right folder (diff)
downloadguru-7b5b7a5652d0d637c1538474374a24c2480fe347.tar.gz
guru-7b5b7a5652d0d637c1538474374a24c2480fe347.tar.bz2
guru-7b5b7a5652d0d637c1538474374a24c2480fe347.zip
dev-cpp/fizz: fix build error with latest gtest
Closes: https://bugs.gentoo.org/820290 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-cpp/fizz')
-rw-r--r--dev-cpp/fizz/fizz-2021.10.25.00.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-cpp/fizz/fizz-2021.10.25.00.ebuild b/dev-cpp/fizz/fizz-2021.10.25.00.ebuild
index a1908fcff..12e7ec567 100644
--- a/dev-cpp/fizz/fizz-2021.10.25.00.ebuild
+++ b/dev-cpp/fizz/fizz-2021.10.25.00.ebuild
@@ -7,14 +7,12 @@ inherit cmake
DESCRIPTION="C++14 implementation of the TLS-1.3 standard"
HOMEPAGE="https://github.com/facebookincubator/fizz"
-
SRC_URI="https://github.com/facebookincubator/fizz/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
-
-CMAKE_USE_DIR="${S}/fizz"
+IUSE="examples test"
RDEPEND="
~dev-cpp/folly-${PV}:=
@@ -29,9 +27,12 @@ RDEPEND="
#TODO: discover if gtest is linked
DEPEND="
${RDEPEND}
- dev-cpp/gtest
+ test? ( <dev-cpp/gtest-1.11.0 )
"
+RESTRICT="!test? ( test )"
+CMAKE_USE_DIR="${S}/fizz"
+
src_prepare() {
cmake_src_prepare
sed -i '/Sodium/d' fizz/cmake/fizz-config.cmake.in || die
@@ -39,6 +40,8 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
+ -DBUILD_EXAMPLES=$(usex examples)
+ -DBUILD_TESTS=$(usex test)
-DLIB_INSTALL_DIR=$(get_libdir)
)