aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuan Liao <liaoyuan@gmail.com>2022-04-01 07:18:07 -0700
committerYuan Liao <liaoyuan@gmail.com>2022-04-01 07:18:09 -0700
commite9a3be3336390fae2754ade9bd8506afa83e2562 (patch)
treeb337db634c2b60bbf44c1ffcca3f2767ad3cacaf /dev-cpp/fizz
parentdev-cpp/wangle: Drop 2022.02.28.00 (diff)
downloadguru-e9a3be3336390fae2754ade9bd8506afa83e2562.tar.gz
guru-e9a3be3336390fae2754ade9bd8506afa83e2562.tar.bz2
guru-e9a3be3336390fae2754ade9bd8506afa83e2562.zip
dev-cpp/fizz: Drop 2022.02.28.00
Dropping 2022.02.28.00 after dependency ~dev-cpp/folly-2022.02.28.00 has been dropped from ::gentoo. Signed-off-by: Yuan Liao <liaoyuan@gmail.com>
Diffstat (limited to 'dev-cpp/fizz')
-rw-r--r--dev-cpp/fizz/Manifest1
-rw-r--r--dev-cpp/fizz/fizz-2022.02.28.00.ebuild49
2 files changed, 0 insertions, 50 deletions
diff --git a/dev-cpp/fizz/Manifest b/dev-cpp/fizz/Manifest
index a3ac9534d..7e54932b0 100644
--- a/dev-cpp/fizz/Manifest
+++ b/dev-cpp/fizz/Manifest
@@ -1,2 +1 @@
-DIST fizz-2022.02.28.00.tar.gz 581059 BLAKE2B 31b086ca41db7919abdfc1fb8f88efe93f09ad59b5727ada2d04bd95f22f03bec7346de3944dad44d688b1281a5d789df2e134c0990dd1c751723b60791c1770 SHA512 ccfd493b04cca5e8e76e64dea2659b88ec1fe0dcdfa3b1133d46fe8d37abc4fc78710c0831c2038ce0806f7ebad47607aa7597f9ee8577b9bbd11436ff1cdeaf
DIST fizz-2022.03.21.00.tar.gz 581670 BLAKE2B 2dc9691abfaf646db56e047a74894b745102764c773b9f244c4b357b74b6d00d1a2548664a5e343f2c5f84458de36d453e99b9901c89bc621c54840a7b45b5e4 SHA512 81a7b764c2c2e17fd5df32a69ecb368eb01df04df6dbd1155a40b68fc39cda4f86ce81afc5c89425a5751ef7f4dbb8a40df8b5095685e72ce5e9043c0a74682e
diff --git a/dev-cpp/fizz/fizz-2022.02.28.00.ebuild b/dev-cpp/fizz/fizz-2022.02.28.00.ebuild
deleted file mode 100644
index 12e7ec567..000000000
--- a/dev-cpp/fizz/fizz-2022.02.28.00.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="C++14 implementation of the TLS-1.3 standard"
-HOMEPAGE="https://github.com/facebookincubator/fizz"
-SRC_URI="https://github.com/facebookincubator/fizz/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="examples test"
-
-RDEPEND="
- ~dev-cpp/folly-${PV}:=
- dev-cpp/gflags
- dev-cpp/glog
- dev-libs/double-conversion
- dev-libs/libevent
- dev-libs/libfmt
- dev-libs/libsodium
- dev-libs/openssl:0=
-"
-#TODO: discover if gtest is linked
-DEPEND="
- ${RDEPEND}
- test? ( <dev-cpp/gtest-1.11.0 )
-"
-
-RESTRICT="!test? ( test )"
-CMAKE_USE_DIR="${S}/fizz"
-
-src_prepare() {
- cmake_src_prepare
- sed -i '/Sodium/d' fizz/cmake/fizz-config.cmake.in || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_EXAMPLES=$(usex examples)
- -DBUILD_TESTS=$(usex test)
- -DLIB_INSTALL_DIR=$(get_libdir)
- )
-
- cmake_src_configure
-}