aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-07-07 18:16:17 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-07-07 18:16:17 +0200
commit37d8d1f21fb6bb7f2a4f694e65ddc5518fba8456 (patch)
treeaaa1457f7a26b44a074dc0f2db3650d6017e9d28 /dev-cpp/parallel-hashmap
parentsci-libs/STRUMPACK: use upstream patch (diff)
downloadguru-37d8d1f21fb6bb7f2a4f694e65ddc5518fba8456.tar.gz
guru-37d8d1f21fb6bb7f2a4f694e65ddc5518fba8456.tar.bz2
guru-37d8d1f21fb6bb7f2a4f694e65ddc5518fba8456.zip
dev-cpp/parallel-hashmap: fix cmake invocation
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-cpp/parallel-hashmap')
-rw-r--r--dev-cpp/parallel-hashmap/Manifest1
-rw-r--r--dev-cpp/parallel-hashmap/parallel-hashmap-1.34-r1.ebuild41
-rw-r--r--dev-cpp/parallel-hashmap/parallel-hashmap-1.35.ebuild12
3 files changed, 7 insertions, 47 deletions
diff --git a/dev-cpp/parallel-hashmap/Manifest b/dev-cpp/parallel-hashmap/Manifest
index d80bc3e49..f947d04bd 100644
--- a/dev-cpp/parallel-hashmap/Manifest
+++ b/dev-cpp/parallel-hashmap/Manifest
@@ -1,2 +1 @@
-DIST parallel-hashmap-1.34.tar.gz 2043028 BLAKE2B 30629288656a22cfd56da9485458f604487383cc5951e230a833b182cbbcc706b78d0b8a45fb76c4fca6da930f49cdb79b2ca63926ca8cd60cc7445b58c8edbd SHA512 3747422e80406aa77b009adee3c16325640dd1044560882fb881dac5ef4109f7d165d26ed7e64002c9285275f95962725ce20c918da12c0c113999c8ca3c7429
DIST parallel-hashmap-1.35.gh.tar.gz 2044770 BLAKE2B 18c4843ebd2ca046e1597a7fc0341440d888c4b39d2355e45b36e02b9f5dcf39baec1826434d70b591e6713fe2ff043a9ec8a68b7b43e0fbb2af176507b738ba SHA512 ffa70a6691784caa8acc6e191b3db4ffdbbc51db86c91118267fac96c178d434f890f773c9b31932eaed15b2cecbd74dcaddacefd0ef9771da0833c90d0f104c
diff --git a/dev-cpp/parallel-hashmap/parallel-hashmap-1.34-r1.ebuild b/dev-cpp/parallel-hashmap/parallel-hashmap-1.34-r1.ebuild
deleted file mode 100644
index 6ef5bc9f6..000000000
--- a/dev-cpp/parallel-hashmap/parallel-hashmap-1.34-r1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Family of header-only, fast and memory-friendly hashmap and btree containers"
-HOMEPAGE="
- https://greg7mdp.github.io/parallel-hashmap/
- https://github.com/greg7mdp/parallel-hashmap
-"
-SRC_URI="https://github.com/greg7mdp/parallel-hashmap/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="examples test"
-
-CDEPEND="dev-libs/cereal"
-DEPEND="test? ( ${CDEPEND} )"
-RDEPEND="${CDEPEND}"
-
-RESTRICT="!test? ( test )"
-
-src_compile() {
- mycmakeargs=(
- PHMAP_BUILD_EXAMPLES=$(usex examples)
- PHMAP_BUILD_TESTS=$(usex test)
- )
-
- cmake_src_compile
-}
-
-src_install() {
- cmake_src_install
- if use examples ; then
- dodoc -r examples
- docompress -x "/usr/share/doc/${PF}/examples"
- fi
-}
diff --git a/dev-cpp/parallel-hashmap/parallel-hashmap-1.35.ebuild b/dev-cpp/parallel-hashmap/parallel-hashmap-1.35.ebuild
index 46dd6b355..2e46da2b8 100644
--- a/dev-cpp/parallel-hashmap/parallel-hashmap-1.35.ebuild
+++ b/dev-cpp/parallel-hashmap/parallel-hashmap-1.35.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+CMAKE_MAKEFILE_GENERATOR=emake
+
inherit cmake
DESCRIPTION="Family of header-only, fast and memory-friendly hashmap and btree containers"
@@ -25,13 +27,13 @@ RDEPEND="${CDEPEND}"
# https://github.com/greg7mdp/parallel-hashmap/issues/154
RESTRICT="test"
-src_compile() {
- mycmakeargs=(
- PHMAP_BUILD_EXAMPLES=$(usex examples)
- PHMAP_BUILD_TESTS=$(usex test)
+src_configure() {
+ local mycmakeargs=(
+ -DPHMAP_BUILD_EXAMPLES=$(usex examples)
+ -DPHMAP_BUILD_TESTS=$(usex test)
)
- cmake_src_compile
+ cmake_src_configure
}
src_install() {