aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Reva <denis7774@gmail.com>2023-02-28 20:32:05 +0500
committerDenis Reva <denis7774@gmail.com>2023-02-28 20:32:05 +0500
commit8bde7c44ed1390cc3f2ae2a7d4ce3a6c8c49e6da (patch)
tree5260307c8a81b2e53449704d6037aad68b7605f1 /dev-cpp/parallel-hashmap
parentsys-fs/dwarfs: finished working (diff)
downloadguru-8bde7c44ed1390cc3f2ae2a7d4ce3a6c8c49e6da.tar.gz
guru-8bde7c44ed1390cc3f2ae2a7d4ce3a6c8c49e6da.tar.bz2
guru-8bde7c44ed1390cc3f2ae2a7d4ce3a6c8c49e6da.zip
dev-cpp/parallel-hashmap: updated to 1.3.8
project accidently switched to semver Signed-off-by: Denis Reva <denis7774@gmail.com>
Diffstat (limited to 'dev-cpp/parallel-hashmap')
-rw-r--r--dev-cpp/parallel-hashmap/Manifest1
-rw-r--r--dev-cpp/parallel-hashmap/metadata.xml4
-rw-r--r--dev-cpp/parallel-hashmap/parallel-hashmap-1.3.8.ebuild46
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-cpp/parallel-hashmap/Manifest b/dev-cpp/parallel-hashmap/Manifest
index f947d04bd..4d6cffc56 100644
--- a/dev-cpp/parallel-hashmap/Manifest
+++ b/dev-cpp/parallel-hashmap/Manifest
@@ -1 +1,2 @@
+DIST parallel-hashmap-1.3.8.tar.gz 2047306 BLAKE2B b56bd2a8f958f69c400e8b736669f7bbe875823ca28370a6ce0f25a6de995a81b4ff8269f84eea3bbdcd62ec96d2a7613d8d414abcf2da6215e476f81927d4ad SHA512 499f132aa1513942762ae5214e9a37915529d60142439d32276d9e68a446c93ecea66caa32ac00bea683e2c932101cd999c8839a89211e91032f777f236181f7
DIST parallel-hashmap-1.35.gh.tar.gz 2044770 BLAKE2B 18c4843ebd2ca046e1597a7fc0341440d888c4b39d2355e45b36e02b9f5dcf39baec1826434d70b591e6713fe2ff043a9ec8a68b7b43e0fbb2af176507b738ba SHA512 ffa70a6691784caa8acc6e191b3db4ffdbbc51db86c91118267fac96c178d434f890f773c9b31932eaed15b2cecbd74dcaddacefd0ef9771da0833c90d0f104c
diff --git a/dev-cpp/parallel-hashmap/metadata.xml b/dev-cpp/parallel-hashmap/metadata.xml
index 3183d009f..c7a8c6eea 100644
--- a/dev-cpp/parallel-hashmap/metadata.xml
+++ b/dev-cpp/parallel-hashmap/metadata.xml
@@ -5,6 +5,10 @@
<email>lssndrbarbieri@gmail.com</email>
<name>Alessandro Barbieri</name>
</maintainer>
+ <maintainer type="person">
+ <email>denis7774@gmail.com</email>
+ <name>Denis Reva</name>
+ </maintainer>
<longdescription lang="en">
Overview
diff --git a/dev-cpp/parallel-hashmap/parallel-hashmap-1.3.8.ebuild b/dev-cpp/parallel-hashmap/parallel-hashmap-1.3.8.ebuild
new file mode 100644
index 000000000..35fd6b2d7
--- /dev/null
+++ b/dev-cpp/parallel-hashmap/parallel-hashmap-1.3.8.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_MAKEFILE_GENERATOR=emake
+
+inherit cmake
+
+DESCRIPTION="Family of header-only, fast and memory-friendly hashmap and btree containers"
+HOMEPAGE="
+ https://greg7mdp.github.io/parallel-hashmap/
+ https://github.com/greg7mdp/parallel-hashmap
+"
+SRC_URI="https://github.com/greg7mdp/parallel-hashmap/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="examples test"
+
+CDEPEND="dev-libs/cereal"
+DEPEND="${CDEPEND} test? ( dev-cpp/gtest )"
+RDEPEND="${CDEPEND}"
+
+# tests will download gtest, not trivial to use the system one
+# https://github.com/greg7mdp/parallel-hashmap/issues/154
+RESTRICT="!test? ( test )"
+src_configure() {
+ local mycmakeargs=(
+ -DPHMAP_BUILD_EXAMPLES=$(usex examples)
+ -DPHMAP_BUILD_TESTS=$(usex test)
+ )
+ if use test; then
+ mycmakeargs+=( -DPHMAP_GTEST_LIBS="gmock -lgmock_main -lgtest -lgtest_main" )
+ fi
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ if use examples ; then
+ dodoc -r examples
+ docompress -x "/usr/share/doc/${PF}/examples"
+ fi
+}