aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortastytea <gentoo@tastytea.de>2024-03-12 09:53:06 +0100
committertastytea <gentoo@tastytea.de>2024-03-12 09:53:06 +0100
commit49a7b84f282e2a1b87495e4b33a8a380b9a3dc1e (patch)
tree707ee002058e877e172774bac8b7ae2497941ae0 /dev-cpp/qt-jdenticon/qt-jdenticon-0.3.0-r1.ebuild
parentnet-irc/thelounge: use python-any-r1 instead and tweak systemd unit (diff)
downloadguru-49a7b84f282e2a1b87495e4b33a8a380b9a3dc1e.tar.gz
guru-49a7b84f282e2a1b87495e4b33a8a380b9a3dc1e.tar.bz2
guru-49a7b84f282e2a1b87495e4b33a8a380b9a3dc1e.zip
dev-cpp/qt-jdenticon: add slot 5 (qt5), fix dep
in preparation for slot 6 (qt6) in the next version Signed-off-by: tastytea <gentoo@tastytea.de>
Diffstat (limited to 'dev-cpp/qt-jdenticon/qt-jdenticon-0.3.0-r1.ebuild')
-rw-r--r--dev-cpp/qt-jdenticon/qt-jdenticon-0.3.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-cpp/qt-jdenticon/qt-jdenticon-0.3.0-r1.ebuild b/dev-cpp/qt-jdenticon/qt-jdenticon-0.3.0-r1.ebuild
new file mode 100644
index 000000000..fafae716b
--- /dev/null
+++ b/dev-cpp/qt-jdenticon/qt-jdenticon-0.3.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils
+
+DESCRIPTION="Qt5 / C++14 Port of Jdenticon"
+HOMEPAGE="https://github.com/Nheko-Reborn/qt-jdenticon"
+SRC_URI="https://github.com/Nheko-Reborn/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="5"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-qt/qtgui:5
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}