aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortastytea <gentoo@tastytea.de>2024-05-08 16:59:01 +0200
committertastytea <gentoo@tastytea.de>2024-05-08 18:49:39 +0200
commit7033de07c5ca0e1b8620428d7d128ee9c1ebf540 (patch)
tree09df5877b3e9beec1406e0f842e21903882d2d96 /dev-cpp/trantor
parentdev-cpp/trantor: add 1.5.18 (diff)
downloadguru-7033de07c5ca0e1b8620428d7d128ee9c1ebf540.tar.gz
guru-7033de07c5ca0e1b8620428d7d128ee9c1ebf540.tar.bz2
guru-7033de07c5ca0e1b8620428d7d128ee9c1ebf540.zip
dev-cpp/trantor: drop 1.5.15
Signed-off-by: tastytea <gentoo@tastytea.de>
Diffstat (limited to 'dev-cpp/trantor')
-rw-r--r--dev-cpp/trantor/Manifest1
-rw-r--r--dev-cpp/trantor/trantor-1.5.15.ebuild54
2 files changed, 0 insertions, 55 deletions
diff --git a/dev-cpp/trantor/Manifest b/dev-cpp/trantor/Manifest
index e92fd7b98..303b697e0 100644
--- a/dev-cpp/trantor/Manifest
+++ b/dev-cpp/trantor/Manifest
@@ -1,3 +1,2 @@
-DIST trantor-1.5.15.tar.gz 153133 BLAKE2B a69e46072269a8664d33d3b3b6575de07c645151a97f60bfe350d52972cf2b48c062a342c7b2ca57566fa213cc56b585b2fdf34b6d0a5f9c533d1c3f6bab2ba6 SHA512 f08bba448229d8121534cade55b74ac0d9cf5deb1c1116794c21fee37f8f8c3b3d5e6618d0806942a9bcf5eb30c87879ddaf1104417fb3fe14de0827670e03e8
DIST trantor-1.5.17.tar.gz 155603 BLAKE2B 25631b3d8882cec58ff8eea2b449e805f846653d79af41a87b6ead6fff5c32dfc40559cdc734f51505a8ca1100b215cb8d66fa5fc5bf5baa96d6a3e93499a330 SHA512 43202240968b90d0e6d211d3b7a918567587e4ad26c360848efee2661cc1d49d35de408db5e2ff7314be879faac99ffa29ffa1f3735f9606d95874130db05250
DIST trantor-1.5.18.tar.gz 155626 BLAKE2B 7fdd5fdd310b783dbc23be7e3594fe3e4e5135c1fcd7c9c96e153ff28397e543a4be50153e54f4a4f648de21d6c9ca5ffa85518806b7e6d91485956f3b3627b3 SHA512 2dba27efad95155a76968959d9bd2510be8502b9424716493f385aebbce2481553cc8fae283076029aed4bef6f0aadb0bec3f9acb98fbca3ef4d49b936558f8c
diff --git a/dev-cpp/trantor/trantor-1.5.15.ebuild b/dev-cpp/trantor/trantor-1.5.15.ebuild
deleted file mode 100644
index 4a18bcd7b..000000000
--- a/dev-cpp/trantor/trantor-1.5.15.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 2021-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Non-blocking I/O tcp network lib based on c++14/17"
-HOMEPAGE="https://github.com/an-tao/trantor"
-SRC_URI="https://github.com/an-tao/trantor/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="adns doc +spdlog +ssl test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- adns? ( net-dns/c-ares:= )
- ssl? ( dev-libs/openssl:= )
- spdlog? (
- dev-libs/spdlog:=
- dev-libs/libfmt:=
- )
-"
-DEPEND="
- ${RDEPEND}
- test? ( dev-cpp/gtest )
-"
-BDEPEND="doc? ( app-text/doxygen[dot] )"
-
-src_prepare() {
- sed -i 's/ -Werror)$/)/' CMakeLists.txt || die "could not remove -Werror"
- cmake_src_prepare
-}
-
-src_configure() {
- local -a mycmakeargs=(
- "-DBUILD_SHARED_LIBS=YES"
- "-DBUILD_DOC=$(usex doc)"
- "-DBUILD_TESTING=$(usex test)"
- "-DBUILD_C-ARES=$(usex adns)"
- "-DTRANTOR_USE_TLS=$(usex ssl openssl none)"
- "-DUSE_SPDLOG=$(usex spdlog)"
- )
-
- cmake_src_configure
-}
-
-src_install() {
- use doc && HTML_DOCS="${BUILD_DIR}/docs/trantor/html/*"
-
- cmake_src_install
-}