aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-02-26 06:43:45 +0100
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-02-26 06:45:35 +0100
commit8de7a5844390037448232bed66f6fb5d8ea9897c (patch)
tree6c62cb48fdbf5dc8729909b57f8421b7d2faac8e /dev-cpp/trantor
parentdev-embedded/rauc: Drop old (diff)
downloadguru-8de7a5844390037448232bed66f6fb5d8ea9897c.tar.gz
guru-8de7a5844390037448232bed66f6fb5d8ea9897c.tar.bz2
guru-8de7a5844390037448232bed66f6fb5d8ea9897c.zip
dev-cpp/trantor: Version bump 1.5.5
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
Diffstat (limited to 'dev-cpp/trantor')
-rw-r--r--dev-cpp/trantor/Manifest1
-rw-r--r--dev-cpp/trantor/trantor-1.5.5.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-cpp/trantor/Manifest b/dev-cpp/trantor/Manifest
index 2ca3f9e4d..3e0912219 100644
--- a/dev-cpp/trantor/Manifest
+++ b/dev-cpp/trantor/Manifest
@@ -1,2 +1,3 @@
DIST trantor-1.5.3.tar.gz 104794 BLAKE2B 47cebfc81543d050aa26e9aa0ec2fc9a30311ef25ab750dfe0086a917cc6c5588029b839b6c6205c7a23511f570e9d1dd0cbfdb8ef6a6769ee2d06095862c12a SHA512 2d032c59ad1b57bb1711fe99436fbc8eec5400d91bf310986cb4985e2c2ce1143844701a67241d0fe8dc7ab706b828feded3138aef8cf9d5620e581a1a770079
DIST trantor-1.5.4.tar.gz 104945 BLAKE2B bb4c038ef4b98eb127ddab313b9184af9829e1198d5bee295be49ae3d8f6941f11d8b3782056ebb7a779cb454f6e09daee464f597ce623ad1065df943ae47042 SHA512 adb98a78d254b19ec0866cf3bfa06011123fca4553e73702024ebe4cde6d95fb1de29d6894d89362339b82e1a6738b32ffc1a682cbb33ae94354df4a45cda8c7
+DIST trantor-1.5.5.tar.gz 106134 BLAKE2B 52af020c2b862532f5a473b7714654d5a1ea93415059aa3675e0c48d630a1b5ef43782a60ca1d09752c1ef9b90dfec19155af39673e25eb0c99dfc40a9dc0ddb SHA512 41068dcefcaf55908735126375b65a83a7d7085f30d5eb14e8d73fa255405ec77164c34b9ef0e5e6da3aeae3e66b9d57d4fca8901d63d4414bf8e857bd25dcd4
diff --git a/dev-cpp/trantor/trantor-1.5.5.ebuild b/dev-cpp/trantor/trantor-1.5.5.ebuild
new file mode 100644
index 000000000..fc1e115da
--- /dev/null
+++ b/dev-cpp/trantor/trantor-1.5.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Non-blocking I/O tcp network lib based on c++14/17"
+HOMEPAGE="https://github.com/an-tao/trantor"
+SRC_URI="https://github.com/an-tao/trantor/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="adns doc +ssl test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ adns? ( net-dns/c-ares )
+ ssl? ( dev-libs/openssl )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-cpp/gtest )
+"
+BDEPEND="doc? ( app-doc/doxygen )"
+
+src_configure() {
+ local -a mycmakeargs=(
+ "-DBUILD_TRANTOR_SHARED=YES"
+ "-DBUILD_DOC=$(usex doc)"
+ "-DBUILD_TESTING=$(usex test)"
+ "-DBUILD_C-ARES=$(usex adns)"
+ "$(cmake_use_find_package ssl OpenSSL)"
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ use doc && HTML_DOCS="${BUILD_DIR}/docs/trantor/html/*"
+
+ cmake_src_install
+}