aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-10-20 19:56:31 +0200
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-10-20 21:03:49 +0200
commitd20ae3238a177ece7076f78ef445dbb69d5e96e0 (patch)
tree6ba4e29675fb3655781cc4a2e4c5c80c52b13f88 /dev-cpp/trantor
parentapp-admin/chezmoi: Bump to v2.7.2 (diff)
downloadguru-d20ae3238a177ece7076f78ef445dbb69d5e96e0.tar.gz
guru-d20ae3238a177ece7076f78ef445dbb69d5e96e0.tar.bz2
guru-d20ae3238a177ece7076f78ef445dbb69d5e96e0.zip
dev-cpp/trantor: Version bump 1.5.2.
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
Diffstat (limited to 'dev-cpp/trantor')
-rw-r--r--dev-cpp/trantor/Manifest1
-rw-r--r--dev-cpp/trantor/trantor-1.5.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-cpp/trantor/Manifest b/dev-cpp/trantor/Manifest
index e33bc9152..6121d49a9 100644
--- a/dev-cpp/trantor/Manifest
+++ b/dev-cpp/trantor/Manifest
@@ -1 +1,2 @@
DIST trantor-1.5.1.tar.gz 102696 BLAKE2B 7670b2e2bb56b703aa387df463433261cff33b5a8682681071ff5159d14a516e11faebde7e2431232ba3651f6420a017491a7468ce3f90c4c099284808e27171 SHA512 9f6664abc94943598805192ee09a98340e6e20efb15e448aac5e21480f1798b0991782d18766f5ef54399251d4980c2f68aeda3136c7e058e3c31623c8f7ce3f
+DIST trantor-1.5.2.tar.gz 104534 BLAKE2B d6c5a1d2eff46f5ddcd2d31d3908ee0ac71c96fde097eb3f46ec368f4292604c2dd0689018c9c7272f1a8479d908e6c486776689d517513c6e15b7392e0c7376 SHA512 e5977023c7b435bb7c9041a57e9b4488f34aa977e81709b3f20ae2c56ff6920ef8a4c64813be36705465ef87015c678537e22e349d1408aeb27b33f80eb38f1b
diff --git a/dev-cpp/trantor/trantor-1.5.2.ebuild b/dev-cpp/trantor/trantor-1.5.2.ebuild
new file mode 100644
index 000000000..2123d8f25
--- /dev/null
+++ b/dev-cpp/trantor/trantor-1.5.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Non-blocking I/O tcp network lib based on c++14/17"
+HOMEPAGE="https://github.com/an-tao/trantor"
+SRC_URI="https://github.com/an-tao/trantor/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="adns doc +ssl test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ adns? ( net-dns/c-ares )
+ ssl? ( dev-libs/openssl )
+"
+DEPEND="
+ ${RDEPEND}
+ doc? ( app-doc/doxygen )
+ test? ( dev-cpp/gtest )
+"
+
+src_prepare() {
+ use ssl || sed -i '/find_package(OpenSSL)/d' CMakeLists.txt || die
+
+ use doc && HTML_DOCS="${BUILD_DIR}/docs/trantor/html/*"
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local -a mycmakeargs=(
+ "-DBUILD_TRANTOR_SHARED=YES"
+ "-DBUILD_DOC=$(usex doc)"
+ "-DBUILD_TESTING=$(usex test)"
+ "-DBUILD_C-ARES=$(usex adns)"
+ )
+
+ cmake_src_configure
+}