aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKamal Abdellatif <gentoo.kamal@tgf.pw>2023-02-12 21:16:38 +0000
committerKamal Abdellatif <gentoo.kamal@tgf.pw>2023-02-12 21:16:38 +0000
commit45227fe0d65a9fe946688daaa32c30935065ff7c (patch)
tree5e582b4e099cd965daa6349745288f84afab3c1e /dev-cpp/xtl
parentdev-vcs/gitqlient: 1.6.1-r1 bump, fix tabs style (diff)
downloadguru-45227fe0d65a9fe946688daaa32c30935065ff7c.tar.gz
guru-45227fe0d65a9fe946688daaa32c30935065ff7c.tar.bz2
guru-45227fe0d65a9fe946688daaa32c30935065ff7c.zip
dev-cpp/xtl: new package, add 0.7.5
Signed-off-by: Kamal Abdellatif <gentoo.kamal@tgf.pw>
Diffstat (limited to 'dev-cpp/xtl')
-rw-r--r--dev-cpp/xtl/Manifest1
-rw-r--r--dev-cpp/xtl/metadata.xml12
-rw-r--r--dev-cpp/xtl/xtl-0.7.5.ebuild57
3 files changed, 70 insertions, 0 deletions
diff --git a/dev-cpp/xtl/Manifest b/dev-cpp/xtl/Manifest
new file mode 100644
index 000000000..8820db2e3
--- /dev/null
+++ b/dev-cpp/xtl/Manifest
@@ -0,0 +1 @@
+DIST xtl-0.7.5.tar.gz 160548 BLAKE2B 61d8c8c8e69722e2d29bd70991840650b22f2f440e2ee8100786869e4410ace8a5063cc0101361aedca963607cf046bb46e923fc096e25d731affdf2876ef4fa SHA512 fb447334f68f255d7d28c9202eee2cec70d007c1031f3756a6acd0cc019c0d95ed1d12ec63f2e9fb3df184f9ec305e6a3c808bb88c1e3eb922916ad059d2e856
diff --git a/dev-cpp/xtl/metadata.xml b/dev-cpp/xtl/metadata.xml
new file mode 100644
index 000000000..db0f046c8
--- /dev/null
+++ b/dev-cpp/xtl/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo.kamal@tgf.pw</email>
+ <name>Kamal Abdellatif</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">xtensor-stack/xtl</remote-id>
+ <doc>https://xtl.readthedocs.io/en/latest/</doc>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-cpp/xtl/xtl-0.7.5.ebuild b/dev-cpp/xtl/xtl-0.7.5.ebuild
new file mode 100644
index 000000000..b1a9cf5da
--- /dev/null
+++ b/dev-cpp/xtl/xtl-0.7.5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit cmake python-any-r1
+
+DESCRIPTION="Algorithms and containers used by the xtensor stack and the xeus stack"
+HOMEPAGE="https://github.com/xtensor-stack/xtl"
+SRC_URI="https://codeload.github.com/xtensor-stack/${PN}/tar.gz/refs/tags/${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="doc test"
+
+BDEPEND="
+ doc? (
+ app-doc/doxygen
+ $(python_gen_any_dep '
+ dev-python/breathe[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ ')
+ )
+ test? ( dev-cpp/doctest )
+"
+
+RESTRICT="!test? ( test )"
+
+python_check_deps() {
+ python_has_version \
+ "dev-python/breathe[${PYTHON_USEDEP}]" \
+ "dev-python/sphinx[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_TESTS=$(usex test) )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ use test && cmake_src_compile xtest
+
+ if use doc; then
+ cd "${WORKDIR}/${P}/docs" || die
+ emake html BUILDDIR="${BUILD_DIR}"
+ HTML_DOCS=( "${BUILD_DIR}/html/." )
+ fi
+}