aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteffen Winter <steffen.winter@proton.me>2024-03-26 14:39:58 +0100
committerSteffen Winter <steffen.winter@proton.me>2024-03-26 14:40:50 +0100
commit082510a288a21536c324bdc538a81d97371727ca (patch)
treef9047cff5c27da5aa5fb720de0b95cfc47b2c4a0 /dev-cpp
parentdev-cpp/scnlib: drop 2.0.1 (diff)
downloadguru-082510a288a21536c324bdc538a81d97371727ca.tar.gz
guru-082510a288a21536c324bdc538a81d97371727ca.tar.bz2
guru-082510a288a21536c324bdc538a81d97371727ca.zip
dev-cpp/scnlib: fix compilation with simdutf-5.0.0
Fixes: https://bugs.gentoo.org/927799 Signed-off-by: Steffen Winter <steffen.winter@proton.me>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/scnlib/files/scnlib-2.0.2-accept-newer-simdutf.patch16
-rw-r--r--dev-cpp/scnlib/files/scnlib-2.0.2-no-external-test-deps.patch (renamed from dev-cpp/scnlib/files/scnlib-2.0.0-no-external-test-deps.patch)0
-rw-r--r--dev-cpp/scnlib/scnlib-2.0.2.ebuild6
3 files changed, 21 insertions, 1 deletions
diff --git a/dev-cpp/scnlib/files/scnlib-2.0.2-accept-newer-simdutf.patch b/dev-cpp/scnlib/files/scnlib-2.0.2-accept-newer-simdutf.patch
new file mode 100644
index 000000000..3e42ae495
--- /dev/null
+++ b/dev-cpp/scnlib/files/scnlib-2.0.2-accept-newer-simdutf.patch
@@ -0,0 +1,16 @@
+diff --git a/cmake/dependencies.cmake b/cmake/dependencies.cmake
+index ae2832b..186fbed 100644
+--- a/cmake/dependencies.cmake
++++ b/cmake/dependencies.cmake
+@@ -61,7 +61,10 @@ endif ()
+ # we don't want to include tests of dependencies, so we need to do some manual work
+
+ if (SCN_USE_EXTERNAL_SIMDUTF)
+- find_package(simdutf 4.0.0 CONFIG REQUIRED)
++ find_package(simdutf 5.0.0 CONFIG)
++ if(NOT simdutf_FOUND)
++ find_package(simdutf 4.0.0 CONFIG REQUIRED)
++ endif()
+ else ()
+ FetchContent_Declare(
+ simdutf
diff --git a/dev-cpp/scnlib/files/scnlib-2.0.0-no-external-test-deps.patch b/dev-cpp/scnlib/files/scnlib-2.0.2-no-external-test-deps.patch
index e78ba0a2a..e78ba0a2a 100644
--- a/dev-cpp/scnlib/files/scnlib-2.0.0-no-external-test-deps.patch
+++ b/dev-cpp/scnlib/files/scnlib-2.0.2-no-external-test-deps.patch
diff --git a/dev-cpp/scnlib/scnlib-2.0.2.ebuild b/dev-cpp/scnlib/scnlib-2.0.2.ebuild
index 9d0703af8..dd3f493e6 100644
--- a/dev-cpp/scnlib/scnlib-2.0.2.ebuild
+++ b/dev-cpp/scnlib/scnlib-2.0.2.ebuild
@@ -22,8 +22,12 @@ BDEPEND="
RESTRICT="!test? ( test )"
+PATCHES=(
+ "${FILESDIR}/${P}-accept-newer-simdutf.patch"
+)
+
src_prepare() {
- use test && eapply "${FILESDIR}/${PN}-2.0.0-no-external-test-deps.patch"
+ use test && eapply "${FILESDIR}/${P}-no-external-test-deps.patch"
cmake_src_prepare
}