aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortastytea <gentoo@tastytea.de>2024-04-12 23:15:30 +0200
committertastytea <gentoo@tastytea.de>2024-04-13 01:08:32 +0200
commit95f2fc77feafa2c85157dd228a9d8ace9ceb8a74 (patch)
treef148ae8c16d4461d31054063f3d766b76b46a195 /dev-cpp
parentdev-libs/libtypec: add myself as ebuild maintainer (diff)
downloadguru-95f2fc77feafa2c85157dd228a9d8ace9ceb8a74.tar.gz
guru-95f2fc77feafa2c85157dd228a9d8ace9ceb8a74.tar.bz2
guru-95f2fc77feafa2c85157dd228a9d8ace9ceb8a74.zip
dev-cpp/trantor: add 1.5.17
Signed-off-by: tastytea <gentoo@tastytea.de>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/trantor/Manifest1
-rw-r--r--dev-cpp/trantor/trantor-1.5.17.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-cpp/trantor/Manifest b/dev-cpp/trantor/Manifest
index 39004f492..6d30f62a4 100644
--- a/dev-cpp/trantor/Manifest
+++ b/dev-cpp/trantor/Manifest
@@ -1,2 +1,3 @@
DIST trantor-1.5.14_p1.tar.gz 152566 BLAKE2B 09ea5e1d35d653073947e177a9630c93b235e84cdc66a69d4a944f656e957afe31206d7b6079b68f7517bfcd9619aa98e7e4bcc32c7873b01e7cfd94e0ea5704 SHA512 0725b66351a036f829499edb19be31f434ebea7133b129d994f3cb1a5e8c08844c181eab383b074bbcc8bf8efe7d761d12c593180d8ac07edf6dd8bde580578c
DIST trantor-1.5.15.tar.gz 153133 BLAKE2B a69e46072269a8664d33d3b3b6575de07c645151a97f60bfe350d52972cf2b48c062a342c7b2ca57566fa213cc56b585b2fdf34b6d0a5f9c533d1c3f6bab2ba6 SHA512 f08bba448229d8121534cade55b74ac0d9cf5deb1c1116794c21fee37f8f8c3b3d5e6618d0806942a9bcf5eb30c87879ddaf1104417fb3fe14de0827670e03e8
+DIST trantor-1.5.17.tar.gz 155603 BLAKE2B 25631b3d8882cec58ff8eea2b449e805f846653d79af41a87b6ead6fff5c32dfc40559cdc734f51505a8ca1100b215cb8d66fa5fc5bf5baa96d6a3e93499a330 SHA512 43202240968b90d0e6d211d3b7a918567587e4ad26c360848efee2661cc1d49d35de408db5e2ff7314be879faac99ffa29ffa1f3735f9606d95874130db05250
diff --git a/dev-cpp/trantor/trantor-1.5.17.ebuild b/dev-cpp/trantor/trantor-1.5.17.ebuild
new file mode 100644
index 000000000..4a18bcd7b
--- /dev/null
+++ b/dev-cpp/trantor/trantor-1.5.17.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Non-blocking I/O tcp network lib based on c++14/17"
+HOMEPAGE="https://github.com/an-tao/trantor"
+SRC_URI="https://github.com/an-tao/trantor/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="adns doc +spdlog +ssl test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ adns? ( net-dns/c-ares:= )
+ ssl? ( dev-libs/openssl:= )
+ spdlog? (
+ dev-libs/spdlog:=
+ dev-libs/libfmt:=
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-cpp/gtest )
+"
+BDEPEND="doc? ( app-text/doxygen[dot] )"
+
+src_prepare() {
+ sed -i 's/ -Werror)$/)/' CMakeLists.txt || die "could not remove -Werror"
+ cmake_src_prepare
+}
+
+src_configure() {
+ local -a mycmakeargs=(
+ "-DBUILD_SHARED_LIBS=YES"
+ "-DBUILD_DOC=$(usex doc)"
+ "-DBUILD_TESTING=$(usex test)"
+ "-DBUILD_C-ARES=$(usex adns)"
+ "-DTRANTOR_USE_TLS=$(usex ssl openssl none)"
+ "-DUSE_SPDLOG=$(usex spdlog)"
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ use doc && HTML_DOCS="${BUILD_DIR}/docs/trantor/html/*"
+
+ cmake_src_install
+}