aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucio Sauer <watermanpaint@posteo.net>2023-08-31 11:59:49 +0200
committerLucio Sauer <watermanpaint@posteo.net>2023-09-02 21:46:28 +0200
commit825f85e9555a52f5c841de0e7071f721f1a6651f (patch)
treeefe331a46963c6b92a039c9ead51e81d46a8688c /dev-games
parentdev-games/liblcf: update HOMEPAGE, SRC_URI (diff)
downloadguru-825f85e9555a52f5c841de0e7071f721f1a6651f.tar.gz
guru-825f85e9555a52f5c841de0e7071f721f1a6651f.tar.bz2
guru-825f85e9555a52f5c841de0e7071f721f1a6651f.zip
dev-games/liblcf: fix html doc install logic
A non-existent or empty directory doc with HTML_DOCS="doc/*" causes einstalldocs to die. Closes: https://bugs.gentoo.org/913357 Signed-off-by: Lucio Sauer <watermanpaint@posteo.net>
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/liblcf/liblcf-0.8.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-games/liblcf/liblcf-0.8.ebuild b/dev-games/liblcf/liblcf-0.8.ebuild
index 9d2f6afc4..0a147ba75 100644
--- a/dev-games/liblcf/liblcf-0.8.ebuild
+++ b/dev-games/liblcf/liblcf-0.8.ebuild
@@ -22,8 +22,6 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="doc? ( app-doc/doxygen[dot] )"
-HTML_DOCS="doc/*"
-
src_configure() {
local mycmakeargs=(
-DBUILD_SHARED_LIBS=True
@@ -42,3 +40,11 @@ src_compile() {
src_test() {
cmake_build check
}
+
+src_install() {
+ cmake_src_install
+ if use doc; then
+ docinto /usr/share/doc/${PF}/html
+ dodoc -r doc/*
+ fi
+}