aboutsummaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-04-27 02:05:48 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-04-27 02:08:37 +0200
commitba022858029a7be644aacd33d9bf86c8d2698b96 (patch)
tree1f3d3bc1ee2c5c5daa4fd9c107de90301b78f046 /dev-ml
parentdev-python/uharfbuzz: add 0.25.0, drop 0.23.0 (diff)
downloadguru-ba022858029a7be644aacd33d9bf86c8d2698b96.tar.gz
guru-ba022858029a7be644aacd33d9bf86c8d2698b96.tar.bz2
guru-ba022858029a7be644aacd33d9bf86c8d2698b96.zip
dev-ml/gapi-ocaml: new package, add 0.4.2
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/gapi-ocaml/Manifest1
-rw-r--r--dev-ml/gapi-ocaml/files/gapi-ocaml-0.4.2-ounit2.patch58
-rw-r--r--dev-ml/gapi-ocaml/gapi-ocaml-0.4.2.ebuild33
-rw-r--r--dev-ml/gapi-ocaml/metadata.xml25
4 files changed, 117 insertions, 0 deletions
diff --git a/dev-ml/gapi-ocaml/Manifest b/dev-ml/gapi-ocaml/Manifest
new file mode 100644
index 0000000000..e804394c78
--- /dev/null
+++ b/dev-ml/gapi-ocaml/Manifest
@@ -0,0 +1 @@
+DIST gapi-ocaml-0.4.2.tar.gz 466749 BLAKE2B 6a3e66618ed9a665de2892dc7657268f3bad43b871d6d761148152d61de2d988bc13b5051e39da4d1ddad0c620237c6018b87cd2303bc086c570aa879c197e4f SHA512 57d933c2d47ef7b80cb55b661f8df1b8642ff301d54f0fd1dfd4a9bc6238a4cb93a308e6918bbbc080fac146cf5fca2ccfe149d0528a63ead5e29e452c9cc427
diff --git a/dev-ml/gapi-ocaml/files/gapi-ocaml-0.4.2-ounit2.patch b/dev-ml/gapi-ocaml/files/gapi-ocaml-0.4.2-ounit2.patch
new file mode 100644
index 0000000000..36098d82ed
--- /dev/null
+++ b/dev-ml/gapi-ocaml/files/gapi-ocaml-0.4.2-ounit2.patch
@@ -0,0 +1,58 @@
+diff --git a/gapi-ocaml.opam b/gapi-ocaml.opam
+index cb9b0fb5..923675d8 100644
+--- a/gapi-ocaml.opam
++++ b/gapi-ocaml.opam
+@@ -15,7 +15,7 @@ depends: [
+ "dune"
+ "ocamlnet" {>= "4.1.4"}
+ "ocurl"
+- "ounit" {with-test}
++ "ounit2" {with-test}
+ "yojson"
+ ]
+ synopsis: "A simple OCaml client for Google Services"
+diff --git a/src/test/dune b/src/test/dune
+index 5d955f42..ef45f0ce 100644
+--- a/src/test/dune
++++ b/src/test/dune
+@@ -1,7 +1,7 @@
+ (executable
+ (name testSuite)
+ (flags (:standard -w -3-6-23-27-32-33-50))
+- (libraries threads oUnit gapi-ocaml))
++ (libraries threads ounit2 gapi-ocaml))
+
+ (alias
+ (name runtest)
+diff --git a/src/test/testSuite.ml b/src/test/testSuite.ml
+index 7851661e..150781f7 100644
+--- a/src/test/testSuite.ml
++++ b/src/test/testSuite.ml
+@@ -76,11 +76,11 @@ let build_suite_from_list test_list =
+
+ let _ =
+ let test_list = ref (core_tests @ model_tests) in
+- let ounit_specs =
++ let ounit2_specs =
+ [
+- ("-verbose", Arg.Unit (fun _ -> ()), "See oUnit doc");
+- ("-only-test", Arg.String (fun _ -> ()), "See oUnit doc");
+- ("-list-test", Arg.String (fun _ -> ()), "See oUnit doc");
++ ("-verbose", Arg.Unit (fun _ -> ()), "See ounit2 doc");
++ ("-only-test", Arg.String (fun _ -> ()), "See ounit2 doc");
++ ("-list-test", Arg.String (fun _ -> ()), "See ounit2 doc");
+ ]
+ in
+ let arg_specs =
+@@ -100,9 +100,9 @@ let _ =
+ ]
+ in
+ let _ =
+- Arg.parse (arg_specs @ ounit_specs)
++ Arg.parse (arg_specs @ ounit2_specs)
+ (fun _ -> ())
+- ("Usage: " ^ Sys.argv.(0) ^ " [-service svc] [-all] [oUnit arguments]")
++ ("Usage: " ^ Sys.argv.(0) ^ " [-service svc] [-all] [ounit2 arguments]")
+ in
+ let _ =
+ (* Reset argument counter, to let OUnit reparse arguments *)
diff --git a/dev-ml/gapi-ocaml/gapi-ocaml-0.4.2.ebuild b/dev-ml/gapi-ocaml/gapi-ocaml-0.4.2.ebuild
new file mode 100644
index 0000000000..3380c8279d
--- /dev/null
+++ b/dev-ml/gapi-ocaml/gapi-ocaml-0.4.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune findlib
+
+DESCRIPTION="A simple OCaml client for Google Services"
+HOMEPAGE="
+ https://opam.ocaml.org/packages/gapi-ocaml/
+ https://github.com/astrada/gapi-ocaml
+"
+
+SRC_URI="https://github.com/astrada/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="ocamlopt test"
+
+RDEPEND="
+ dev-ml/ocurl:=
+ >=dev-ml/ocamlnet-4.1.4:=
+ dev-ml/cryptokit:=
+ dev-ml/yojson:=
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-ml/ounit2 )
+"
+
+RESTRICT="!test? ( test )"
+PATCHES=( "${FILESDIR}/${P}-ounit2.patch" )
diff --git a/dev-ml/gapi-ocaml/metadata.xml b/dev-ml/gapi-ocaml/metadata.xml
new file mode 100644
index 0000000000..6083d22a6a
--- /dev/null
+++ b/dev-ml/gapi-ocaml/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <description>co-maintainers welcome</description>
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <longdescription lang="en">gapi-ocaml is a simple, unofficial, OCaml client for Google Services.
+The library supports ClientLogin, OAuth 1.0a, and OAuth 2.0
+authentication. Supported RESTful APIs: Calendar APIs v3, Google+ API
+v1, Tasks API v1, APIs Discovery Service v1, URL Shortener API v1,
+OAuth2 API v2, Custom Search API v1, Google Analytics API v3, Page
+Speed Online API v1, Blogger API v2, Site Verification API v1, AdSense
+Management API v1.4, BigQuery API v2, Drive API v2, Drive API v3,
+Gmail API v1.</longdescription>
+ <upstream>
+ <bugs-to>https://github.com/astrada/gapi-ocaml/issues</bugs-to>
+ <remote-id type="github">astrada/gapi-ocaml</remote-id>
+ <maintainer>
+ <name>Alessandro Strada</name>
+ <email>alessandro.strada@gmail.com</email>
+ </maintainer>
+ </upstream>
+</pkgmetadata>