aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2023-04-19 02:05:31 +0300
committerSergey Torokhov <torokhov-s-a@yandex.ru>2023-04-19 02:57:48 +0300
commitcafd796f3a477cddfbcbf9c9bfb0e61702e9fb5b (patch)
treeaf5c77f043e5ebf08bda010f385d07189f66417c /dev-util
parentdev-libs/m_cli2: rename to M_CLI2 to follow upstream naming (diff)
downloadguru-cafd796f3a477cddfbcbf9c9bfb0e61702e9fb5b.tar.gz
guru-cafd796f3a477cddfbcbf9c9bfb0e61702e9fb5b.tar.bz2
guru-cafd796f3a477cddfbcbf9c9bfb0e61702e9fb5b.zip
dev-util/fpm: replace repetitive build flags with BUILD_FLAGS array
Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/fpm/fpm-0.7.0-r2.ebuild26
1 files changed, 11 insertions, 15 deletions
diff --git a/dev-util/fpm/fpm-0.7.0-r2.ebuild b/dev-util/fpm/fpm-0.7.0-r2.ebuild
index fba8f63c42..38cc9186de 100644
--- a/dev-util/fpm/fpm-0.7.0-r2.ebuild
+++ b/dev-util/fpm/fpm-0.7.0-r2.ebuild
@@ -52,7 +52,7 @@ pkg_pretend() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
-set_omp_flag() {
+set_build_flags() {
OMPFLAG=""
if use openmp ; then
case $(tc-getFC) in
@@ -62,13 +62,19 @@ set_omp_flag() {
die "Sorry, only GNU gfortran is currently supported in the ebuild" ;;
esac
fi
+
+ BUILD_FLAGS=( --compiler "$(tc-getFC)"
+ --flag "${FCFLAGS} ${OMPFLAG} -I/usr/include/toml-f -I/usr/include/M_CLI2"
+ --c-compiler "$(tc-getCC)" --c-flag "${CFLAGS}"
+ --cxx-compiler "$(tc-getCXX)" --cxx-flag "${CXXFLAGS}"
+ --archiver "$(tc-getAR)" --link-flag "${LDFLAGS}" )
}
pkg_setup() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
fortran-2_pkg_setup
python-any-r1_pkg_setup
- set_omp_flag
+ set_build_flags
}
src_prepare() {
@@ -88,10 +94,7 @@ src_compile() {
"$(tc-getFC)" -J "${BSDIR}" -o "${BSDIR}"/fpm "${BSDIR}/${P}.F90" || die
# Use the bootstrap binary to build the feature complete fpm version
- "${BSDIR}"/fpm build --verbose --compiler "$(tc-getFC)" --flag "${FCFLAGS} ${OMPFLAG} -I/usr/include/toml-f -I/usr/include/M_CLI2" \
- --c-compiler "$(tc-getCC)" --c-flag "${CFLAGS}" \
- --cxx-compiler "$(tc-getCXX)" --cxx-flag "${CXXFLAGS}" \
- --archiver "$(tc-getAR)" --link-flag "${LDFLAGS}" || die
+ "${BSDIR}"/fpm build --verbose "${BUILD_FLAGS[@]}" || die
if use doc ; then
einfo "Build API documentation:"
@@ -100,19 +103,12 @@ src_compile() {
}
src_test() {
- "${BSDIR}"/fpm test --verbose --compiler "$(tc-getFC)" --flag "${FCFLAGS} ${OMPFLAG} -I/usr/include/toml-f -I/usr/include/M_CLI2" \
- --c-compiler "$(tc-getCC)" --c-flag "${CFLAGS}" \
- --cxx-compiler "$(tc-getCXX)" --cxx-flag "${CXXFLAGS}" \
- --archiver="$(tc-getAR)" --link-flag "${LDFLAGS}" || die
+ "${BSDIR}"/fpm test --verbose "${BUILD_FLAGS[@]}" || die
}
src_install() {
# Set prefix and pass all used env flags to avoid recompiling with default values
- "${BSDIR}"/fpm install --prefix "${ED}/usr" \
- --compiler "$(tc-getFC)" --flag "${FCFLAGS} ${OMPFLAG} -I/usr/include/toml-f -I/usr/include/M_CLI2" \
- --c-compiler "$(tc-getCC)" --c-flag "${CFLAGS}" \
- --cxx-compiler "$(tc-getCXX)" --cxx-flag "${CXXFLAGS}" \
- --archiver="$(tc-getAR)" --link-flag "${LDFLAGS}" || die
+ "${BSDIR}"/fpm install --prefix "${ED}/usr" "${BUILD_FLAGS[@]}" || die
use doc && HTML_DOCS=( "${S}"/fpm-doc/. )
einstalldocs