aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2022-12-11 11:21:06 +0300
committerSergey Torokhov <torokhov-s-a@yandex.ru>2022-12-11 11:21:06 +0300
commit84cae8a3f91eba737e2dd8dd5824db8e61af42c2 (patch)
tree8beaa384fbc17dee95424b0447fba96712be73ca /dev-vcs
parentsys-libs/libfixposix: remove .la file (diff)
downloadguru-84cae8a3f91eba737e2dd8dd5824db8e61af42c2.tar.gz
guru-84cae8a3f91eba737e2dd8dd5824db8e61af42c2.tar.bz2
guru-84cae8a3f91eba737e2dd8dd5824db8e61af42c2.zip
dev-vcs/gitqlient: 1.6.0 version bump
Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/gitqlient/Manifest1
-rw-r--r--dev-vcs/gitqlient/gitqlient-1.6.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-vcs/gitqlient/Manifest b/dev-vcs/gitqlient/Manifest
index 9c7aa605c8..bb6603c4d4 100644
--- a/dev-vcs/gitqlient/Manifest
+++ b/dev-vcs/gitqlient/Manifest
@@ -1 +1,2 @@
DIST gitqlient-1.5.0.tar.gz 4969914 BLAKE2B 9739e333fa20fee724f948cf7a8109b932b7ac8ebfe8465cdc374774f21c105d6467078322012eec8ce82c1b92f9b5e4f32b24885d5ab218b64544a2c2ad6504 SHA512 32f838c75314aca67880354127f2cdc00ed6ce0c6b315dd9571d00dbebca4896e975d73ef779dae5c1953f62387992e573ee95f32545e41e59f5066ae8f11662
+DIST gitqlient-1.6.0.tar.gz 4971921 BLAKE2B 0bbcd3eeb6062e947929bb0d65135ebb2187694f1516b669238afa879d52daa5ca728b7663373257229b5cf808b31fd0aa6bfcb3fe8859f909ba764252ea336f SHA512 2552b61cb3a2a358ae953cc399f16f6091b45050cd900969553d80148f4f45ec1f522458b6cf189ec700fb48253f61e260af9b8040788e86f15172d8e2277dc7
diff --git a/dev-vcs/gitqlient/gitqlient-1.6.0.ebuild b/dev-vcs/gitqlient/gitqlient-1.6.0.ebuild
new file mode 100644
index 0000000000..567e480ed7
--- /dev/null
+++ b/dev-vcs/gitqlient/gitqlient-1.6.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature qmake-utils xdg
+
+MY_PN="GitQlient"
+
+DESCRIPTION="Multi-platform Git client written with Qt"
+HOMEPAGE="https://github.com/francescmm/GitQlient"
+
+SRC_URI="https://github.com/francescmm/${MY_PN}/releases/download/v${PV}/${PN}_${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+S="${WORKDIR}/${PN}_${PV}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="
+ ${DEPEND}
+ dev-vcs/git
+"
+
+src_prepare() {
+ default
+
+ # Drop 'fatal' warning on version detection via git command:
+ sed -i -e "/^GQ_SHA/d" \
+ -e "/VERSION =/s| \$\$system(git rev-parse --short HEAD)||" "${MY_PN}".pro || die
+
+ sed -i -e "s/Office/Development/" "${S}/src/resources/${PN}.desktop" || die
+
+ # Revert changes that brake build
+ sed -i -e "s/QT_DISABLE_DEPRECATED_BEFORE=0x051200/QT_DISABLE_DEPRECATED_BEFORE=0x050900/" "${MY_PN}".pro || die
+}
+
+src_configure() {
+ eqmake5 PREFIX=/usr "${MY_PN}".pro
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}
+
+pkg_postinst() {
+ optfeature "Jenkins and/or GitServer plugins support" dev-qt/qtwebchannel:5 dev-qt/qtwebengine:5[widgets]
+}