aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-11-04 20:23:50 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-11-04 20:23:50 +0500
commit901c0f69430176e7886747c8f2d367181bf7574f (patch)
treec1cd3f3a00ad4f2e6bc97b2a648169beda2b8ef0 /dev-vcs
parentdev-python/hunter: try to simplify tests (diff)
downloadguru-901c0f69430176e7886747c8f2d367181bf7574f.tar.gz
guru-901c0f69430176e7886747c8f2d367181bf7574f.tar.bz2
guru-901c0f69430176e7886747c8f2d367181bf7574f.zip
dev-vcs/got: add 0.78, drop 0.76
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/got/Manifest2
-rw-r--r--dev-vcs/got/got-0.78.ebuild (renamed from dev-vcs/got/got-0.76.ebuild)40
2 files changed, 22 insertions, 20 deletions
diff --git a/dev-vcs/got/Manifest b/dev-vcs/got/Manifest
index a48601857..02fadc7b8 100644
--- a/dev-vcs/got/Manifest
+++ b/dev-vcs/got/Manifest
@@ -1,2 +1,2 @@
-DIST got-portable-0.76.tar.gz 842394 BLAKE2B a2fa8ee75c7934f4b2dd901c95c54e7ba4c4ec36007fcd4912b7ae78cec83cc1baa0e9553ec13cd7e0aaaf884291d9087c544da7c7cb071c7bf90bdee4c7287f SHA512 c51bc6a6d537c12f9437e3dab44779157a56aea6dea4a3ad222c53406f3ea5f2215d9a1ccd75496fcf60fb3b69e50572e89b82024f1195b8a57993e92bbc068f
DIST got-portable-0.77.tar.gz 860031 BLAKE2B 51bcac0d7393a5620d542c23db0a25db6ebcc4ea32faa18f08d59b6567721a4611ee7dbc0fd7b718810ba5e694b91209f7e645c54328255364caff224efc2841 SHA512 7135d63077457abf8320924ba1ec3586f4ae9d32fce2fe9493325765934f2d8c023ea399ba875c8f27d3e95437d1940bc60b4df8669060c3171cbc4df8103ce8
+DIST got-portable-0.78.tar.gz 880783 BLAKE2B 363c19bba0b4fa29a80bc9fcd26cd69370b44894d905f3ccafc201ffcdf6d7e43b1dac74d004cb1b4ad7af07a751d3ac33160fed23fb4e7f57ec163589ae1ad1 SHA512 597d0c65ea2ed01e211a17e3ff11d5fa3792bda53cb60fd54124ef8bc2f6153102ad6eb6e8bf6686bc9abef4dace8997e35938b570429dc0077ca259ab57bef0
diff --git a/dev-vcs/got/got-0.76.ebuild b/dev-vcs/got/got-0.78.ebuild
index f8642b4cf..8224981b6 100644
--- a/dev-vcs/got/got-0.76.ebuild
+++ b/dev-vcs/got/got-0.78.ebuild
@@ -3,38 +3,40 @@
EAPI=8
-inherit toolchain-funcs
-
-MY_PN="${PN}-portable"
+MY_P="${PN}-portable-${PV}"
DESCRIPTION="Portable version of the Game of Trees version control system"
HOMEPAGE="https://gameoftrees.org"
-SRC_URI="https://gameoftrees.org/releases/portable/${MY_PN}-${PV}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
+SRC_URI="https://gameoftrees.org/releases/portable/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="ISC"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-DEPEND="
+RDEPEND="
+ dev-libs/libevent:=
sys-libs/ncurses:=[unicode(+)]
sys-libs/zlib:=
- elibc_Darwin? ( dev-libs/ossp-uuid )
- elibc_SunOS? ( sys-libs/libuuid )
- !elibc_Darwin? ( dev-libs/libbsd )
- !elibc_Darwin? ( !elibc_SunOS? (
- app-crypt/libmd
- sys-apps/util-linux
- ) )
+ elibc_Darwin? (
+ dev-libs/ossp-uuid
+ )
+ elibc_SunOS? (
+ sys-libs/libuuid
+ )
+ !elibc_Darwin? (
+ dev-libs/libbsd
+ !elibc_SunOS? (
+ app-crypt/libmd
+ sys-apps/util-linux
+ )
+ )
+"
+DEPEND="${RDEPEND}
+ kernel_linux? ( sys-kernel/linux-headers )
"
BDEPEND="
virtual/pkgconfig
virtual/yacc
- kernel_linux? ( sys-kernel/linux-headers )
"
-RDEPEND="${DEPEND}"
DOCS=( CHANGELOG CHANGES README TODO )
-
-src_compile() {
- emake AR=$(tc-getAR) GOT_RELEASE=Yes
-}