aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-04-15 20:30:46 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-04-15 20:31:16 +0200
commit316d90e0320632adf3ec1b62172cc9fb13e9b4bc (patch)
treebec6c2eacc334985099a50fe6bc9aa705380e262 /games-action
parentnet-dialup/tio: drop 1.36 (diff)
downloadguru-316d90e0320632adf3ec1b62172cc9fb13e9b4bc.tar.gz
guru-316d90e0320632adf3ec1b62172cc9fb13e9b4bc.tar.bz2
guru-316d90e0320632adf3ec1b62172cc9fb13e9b4bc.zip
games-action/polymc: treeclean, moved to ::gentoo
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/polymc/Manifest1
-rw-r--r--games-action/polymc/metadata.xml17
-rw-r--r--games-action/polymc/polymc-1.1.1.ebuild108
-rw-r--r--games-action/polymc/polymc-9999.ebuild108
4 files changed, 0 insertions, 234 deletions
diff --git a/games-action/polymc/Manifest b/games-action/polymc/Manifest
deleted file mode 100644
index b44203e704..0000000000
--- a/games-action/polymc/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST polymc-1.1.1.tar.gz 5116164 BLAKE2B ca251cac3c8ea21de8a59297a0e637dac078d751476fec5fe86696df270c63ff079779056f016fa656506ea205bb7ace50ab6e0df190ffca14e43297b92292af SHA512 db32479e9e8a92ec61292c97281673b3084e1085d29b764214834de872d9eddf2ed1d2e383bcd79197e0c9321eec025af652b12c863596ff6abb0f5fba9a7af5
diff --git a/games-action/polymc/metadata.xml b/games-action/polymc/metadata.xml
deleted file mode 100644
index a3aeebb29d..0000000000
--- a/games-action/polymc/metadata.xml
+++ /dev/null
@@ -1,17 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>flowlnlnln@gmail.com</email>
- <name>Thiago Donato Ferreira</name>
- </maintainer>
- <maintainer type="person">
- <email>swurl@swurl.xyz</email>
- <name>Carson Rueter</name>
- </maintainer>
- <upstream>
- <bugs-to>https://github.com/PolyMC/PolyMC/issues</bugs-to>
- <doc>https://polymc.org/wiki/</doc>
- </upstream>
- <longdescription lang="en">PolyMC is a multi-instance Minecraft launcher focused on user freedom, redistributability, and simplicity.</longdescription>
-</pkgmetadata>
diff --git a/games-action/polymc/polymc-1.1.1.ebuild b/games-action/polymc/polymc-1.1.1.ebuild
deleted file mode 100644
index bc6b3a0981..0000000000
--- a/games-action/polymc/polymc-1.1.1.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake java-pkg-2 optfeature xdg
-
-HOMEPAGE="https://polymc.org/"
-DESCRIPTION="A custom, open source Minecraft launcher"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
-
- EGIT_REPO_URI="
- https://github.com/PolyMC/PolyMC
- https://github.com/MultiMC/libnbtplusplus
- https://github.com/stachenov/quazip
- "
-
- # Include all submodules
- EGIT_SUBMODULES=( '*' )
-else
- MY_PN="PolyMC"
-
- # Let's use the vendored tarball to avoid dealing with the submodules directly
- SRC_URI="
- https://github.com/PolyMC/PolyMC/releases/download/${PV}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz
- "
-
- # The PolyMC's files are unpacked to ${WORKDIR}/PolyMC-${PV}
- S="${WORKDIR}/${MY_PN}-${PV}"
-
- KEYWORDS="~amd64"
-fi
-
-# Apache-2.0 for MultiMC (PolyMC is forked from it)
-# GPL-3 for PolyMC
-# LGPL-3 for libnbtplusplus
-# LGPL-2.1 with linking exception for Quazip
-# See the rest of PolyMC's libraries at https://github.com/PolyMC/PolyMC/tree/develop/libraries
-LICENSE="Apache-2.0 Boost-1.0 BSD BSD-2 GPL-2+ GPL-3 LGPL-3 LGPL-2.1-with-linking-exception OFL-1.1 MIT"
-
-SLOT="0"
-
-IUSE="debug"
-
-MIN_QT="5.6.0"
-
-QT_DEPS="
- >=dev-qt/qtcore-${MIN_QT}:5
- >=dev-qt/qttest-${MIN_QT}:5
- >=dev-qt/qtconcurrent-${MIN_QT}:5
- >=dev-qt/qtgui-${MIN_QT}:5
- >=dev-qt/qtnetwork-${MIN_QT}:5
- >=dev-qt/qtwidgets-${MIN_QT}:5
- >=dev-qt/qtxml-${MIN_QT}:5
-"
-
-DEPEND="
- ${QT_DEPS}
- >=virtual/jdk-1.8.0:*
- media-libs/libglvnd
- sys-libs/zlib
-"
-
-# At run-time we don't depend on JDK, only JRE
-# And we need more than just the GL headers
-RDEPEND="
- ${QT_DEPS}
- >=virtual/jre-1.8.0:*
- virtual/opengl
- sys-libs/zlib
-"
-
-src_prepare() {
- cmake_src_prepare
-}
-
-src_configure(){
- if use debug; then
- CMAKE_BUILD_TYPE=Debug
- else
- # Prepare for LTO in 1.2.0 (?)
- # See https://github.com/PolyMC/PolyMC/pull/333
- CMAKE_BUILD_TYPE=Release
- fi
-
- local mycmakeargs=(
- # Do a system install
- -DLauncher_PORTABLE=0
- -DCMAKE_INSTALL_PREFIX="/usr"
- # Resulting binary is named polymc
- -DLauncher_APP_BINARY_NAME="${PN}"
- )
-
- cmake_src_configure
-}
-
-src_compile(){
- cmake_src_compile
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- # https://github.com/PolyMC/PolyMC/issues/227
- optfeature "old Minecraft (<= 1.12.2) support" x11-libs/libXrandr
-}
diff --git a/games-action/polymc/polymc-9999.ebuild b/games-action/polymc/polymc-9999.ebuild
deleted file mode 100644
index bc6b3a0981..0000000000
--- a/games-action/polymc/polymc-9999.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake java-pkg-2 optfeature xdg
-
-HOMEPAGE="https://polymc.org/"
-DESCRIPTION="A custom, open source Minecraft launcher"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
-
- EGIT_REPO_URI="
- https://github.com/PolyMC/PolyMC
- https://github.com/MultiMC/libnbtplusplus
- https://github.com/stachenov/quazip
- "
-
- # Include all submodules
- EGIT_SUBMODULES=( '*' )
-else
- MY_PN="PolyMC"
-
- # Let's use the vendored tarball to avoid dealing with the submodules directly
- SRC_URI="
- https://github.com/PolyMC/PolyMC/releases/download/${PV}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz
- "
-
- # The PolyMC's files are unpacked to ${WORKDIR}/PolyMC-${PV}
- S="${WORKDIR}/${MY_PN}-${PV}"
-
- KEYWORDS="~amd64"
-fi
-
-# Apache-2.0 for MultiMC (PolyMC is forked from it)
-# GPL-3 for PolyMC
-# LGPL-3 for libnbtplusplus
-# LGPL-2.1 with linking exception for Quazip
-# See the rest of PolyMC's libraries at https://github.com/PolyMC/PolyMC/tree/develop/libraries
-LICENSE="Apache-2.0 Boost-1.0 BSD BSD-2 GPL-2+ GPL-3 LGPL-3 LGPL-2.1-with-linking-exception OFL-1.1 MIT"
-
-SLOT="0"
-
-IUSE="debug"
-
-MIN_QT="5.6.0"
-
-QT_DEPS="
- >=dev-qt/qtcore-${MIN_QT}:5
- >=dev-qt/qttest-${MIN_QT}:5
- >=dev-qt/qtconcurrent-${MIN_QT}:5
- >=dev-qt/qtgui-${MIN_QT}:5
- >=dev-qt/qtnetwork-${MIN_QT}:5
- >=dev-qt/qtwidgets-${MIN_QT}:5
- >=dev-qt/qtxml-${MIN_QT}:5
-"
-
-DEPEND="
- ${QT_DEPS}
- >=virtual/jdk-1.8.0:*
- media-libs/libglvnd
- sys-libs/zlib
-"
-
-# At run-time we don't depend on JDK, only JRE
-# And we need more than just the GL headers
-RDEPEND="
- ${QT_DEPS}
- >=virtual/jre-1.8.0:*
- virtual/opengl
- sys-libs/zlib
-"
-
-src_prepare() {
- cmake_src_prepare
-}
-
-src_configure(){
- if use debug; then
- CMAKE_BUILD_TYPE=Debug
- else
- # Prepare for LTO in 1.2.0 (?)
- # See https://github.com/PolyMC/PolyMC/pull/333
- CMAKE_BUILD_TYPE=Release
- fi
-
- local mycmakeargs=(
- # Do a system install
- -DLauncher_PORTABLE=0
- -DCMAKE_INSTALL_PREFIX="/usr"
- # Resulting binary is named polymc
- -DLauncher_APP_BINARY_NAME="${PN}"
- )
-
- cmake_src_configure
-}
-
-src_compile(){
- cmake_src_compile
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- # https://github.com/PolyMC/PolyMC/issues/227
- optfeature "old Minecraft (<= 1.12.2) support" x11-libs/libXrandr
-}