aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuel Bauer <samuel.bauer@yahoo.fr>2023-06-24 14:05:57 +0200
committerSamuel Bauer <samuel.bauer@yahoo.fr>2023-06-24 14:05:57 +0200
commitc8247708a2521c325b84d7bb0e265058427762e8 (patch)
tree428eb73898114e0fdfa5cff77f1c5e264763cc62 /games-emulation
parentapp-admin/pulumi-bin: add 3.73.0 (diff)
downloadguru-c8247708a2521c325b84d7bb0e265058427762e8.tar.gz
guru-c8247708a2521c325b84d7bb0e265058427762e8.tar.bz2
guru-c8247708a2521c325b84d7bb0e265058427762e8.zip
games-emulation/flycast: update vulkan unbundling
Signed-off-by: Samuel Bauer <samuel.bauer@yahoo.fr>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/flycast/flycast-9999.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/games-emulation/flycast/flycast-9999.ebuild b/games-emulation/flycast/flycast-9999.ebuild
index a77d24c1c2..25e3b4ba5c 100644
--- a/games-emulation/flycast/flycast-9999.ebuild
+++ b/games-emulation/flycast/flycast-9999.ebuild
@@ -88,6 +88,10 @@ src_prepare() {
# Vulkan-header
sed -i -e '/add_subdirectory(core.*Vulkan-Headers)$/,/Vulkan::Headers/d' \
-e '/core\/deps\/Vulkan-Headers\/include)/d' CMakeLists.txt
+ sed -i -e 's:SPIRV/GlslangToSpv.h:glslang/&:' core/rend/vulkan/compiler.cpp
+ if use vulkan; then
+ sed -i -e '$atarget_link_libraries(${PROJECT_NAME} PRIVATE glslang-default-resource-limits)' CMakeLists.txt
+ fi
# Do not use ccache
sed -i -e '/find_program(CCACHE_PROGRAM ccache)/d' CMakeLists.txt