aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Frei <freijon@pm.me>2021-05-23 08:50:17 +0200
committerJonas Frei <freijon@pm.me>2021-05-23 11:40:08 +0200
commite35221bcbfc0092b4bb4225bd6699983dffb3c17 (patch)
tree4d3110d1680551500df9b6ad8858c7234eff104b /games-engines
parentapp-misc/watchexec: remove old (diff)
downloadguru-e35221bcbfc0092b4bb4225bd6699983dffb3c17.tar.gz
guru-e35221bcbfc0092b4bb4225bd6699983dffb3c17.tar.bz2
guru-e35221bcbfc0092b4bb4225bd6699983dffb3c17.zip
games-engines/fs2_open:
Initial commit for games-engines/fs2_open Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Jonas Frei <freijon@pm.me>
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/fs2_open/files/fs2_open-21.2.0-make-arch-independent.patch14
-rw-r--r--games-engines/fs2_open/fs2_open-21.2.0.ebuild61
-rw-r--r--games-engines/fs2_open/metadata.xml18
3 files changed, 93 insertions, 0 deletions
diff --git a/games-engines/fs2_open/files/fs2_open-21.2.0-make-arch-independent.patch b/games-engines/fs2_open/files/fs2_open-21.2.0-make-arch-independent.patch
new file mode 100644
index 000000000..8bd511129
--- /dev/null
+++ b/games-engines/fs2_open/files/fs2_open-21.2.0-make-arch-independent.patch
@@ -0,0 +1,14 @@
+--- fs2_open-21.2.0/cmake/version.cmake 2021-05-22 20:20:18.448441242 +0200
++++ fs2_open-21.2.0/cmake/version.cmake 2021-05-22 20:21:05.493447003 +0200
+@@ -35,11 +35,6 @@
+ SET(FSO_BINARY_SUFFIX "${FSO_VERSION_MAJOR}_${FSO_VERSION_MINOR}_${FSO_VERSION_BUILD}_${FSO_VERSION_REVISION_STR}")
+ ENDIF()
+
+-IF(IS_64BIT)
+- # This is a 64-bit builds
+- SET(FSO_BINARY_SUFFIX "${FSO_BINARY_SUFFIX}_x64")
+-ENDIF()
+-
+ IF (NOT "${FSO_INSTRUCTION_SET}" STREQUAL "")
+ SET(FSO_BINARY_SUFFIX "${FSO_BINARY_SUFFIX}_${FSO_INSTRUCTION_SET}")
+ ENDIF()
diff --git a/games-engines/fs2_open/fs2_open-21.2.0.ebuild b/games-engines/fs2_open/fs2_open-21.2.0.ebuild
new file mode 100644
index 000000000..11720db3a
--- /dev/null
+++ b/games-engines/fs2_open/fs2_open-21.2.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit git-r3
+inherit cmake
+
+# Replace "." with "_" in version
+_PV=${PV//./_}
+
+DESCRIPTION="FreeSpace2 Source Code Project game engine"
+HOMEPAGE="https://github.com/scp-fs2open/fs2open.github.com/"
+EGIT_REPO_URI="https://github.com/scp-fs2open/fs2open.github.com.git"
+EGIT_COMMIT="release_${_PV}"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ media-libs/libjpeg-turbo
+ media-libs/libpng
+ media-libs/libtheora
+ media-libs/libvorbis
+ >=dev-lang/lua-5.1.0:*
+ media-libs/mesa
+ media-libs/openal
+ media-libs/libsdl2
+ media-libs/glu
+ dev-libs/jansson
+ app-arch/lz4
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+CMAKE_BUILD_TYPE=Release
+
+src_prepare() {
+ eapply "${FILESDIR}/${P}-make-arch-independent.patch"
+ eapply_user
+ cmake_src_prepare
+}
+
+src_install() {
+ exeinto "/opt/${PN}"
+ doexe "${BUILD_DIR}/bin/${PN}_${_PV}"
+ insinto "/opt/${PN}"
+ doins "${BUILD_DIR}/bin/libRocketControls.so"
+ doins "${BUILD_DIR}/bin/libRocketControlsLua.so"
+ doins "${BUILD_DIR}/bin/libRocketCore.so"
+ doins "${BUILD_DIR}/bin/libRocketCoreLua.so"
+ doins "${BUILD_DIR}/bin/libRocketDebugger.so"
+ doins "${BUILD_DIR}/bin/libdiscord-rpc.so"
+}
+
+pkg_postinst() {
+ einfo "This package only generates the engine binary."
+ einfo "The retail Freespace 2 data is required to play the"
+ einfo "original game and most mods."
+}
diff --git a/games-engines/fs2_open/metadata.xml b/games-engines/fs2_open/metadata.xml
new file mode 100644
index 000000000..ae3fd23ea
--- /dev/null
+++ b/games-engines/fs2_open/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Jonas Frei</name>
+ <email>freijon@pm.me</email>
+ </maintainer>
+ <longdescription>
+ fs2_open is the game enginge of the FreeSpace2 Source Code Project.
+ This package is not the complete game, but rather the game engine
+ that runs the game. The game data files have to be installed
+ manually.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">scp-fs2open/fs2open.github.com</remote-id>
+ <bugs-to>https://github.com/scp-fs2open/fs2open.github.com/issues</bugs-to>
+ </upstream>
+</pkgmetadata>