aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2021-08-12 14:31:38 +0200
committerFlorian Schmaus <flow@gentoo.org>2021-08-12 14:31:38 +0200
commitea03cb3a1545a841ced2af3467318e5d18c43047 (patch)
tree1527226d2926560c4dfaf856f3e9296ef7d3fd54 /games-engines
parentapp-misc/jdupes: Add ebuild for jdupes duplicate finder (diff)
downloadguru-ea03cb3a1545a841ced2af3467318e5d18c43047.tar.gz
guru-ea03cb3a1545a841ced2af3467318e5d18c43047.tar.bz2
guru-ea03cb3a1545a841ced2af3467318e5d18c43047.zip
games-engines/instead: migrate to plocale eclass
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/instead/instead-3.3.5.ebuild8
-rw-r--r--games-engines/instead/instead-9999.ebuild8
2 files changed, 8 insertions, 8 deletions
diff --git a/games-engines/instead/instead-3.3.5.ebuild b/games-engines/instead/instead-3.3.5.ebuild
index f25d0ad53..fd8a67314 100644
--- a/games-engines/instead/instead-3.3.5.ebuild
+++ b/games-engines/instead/instead-3.3.5.ebuild
@@ -7,7 +7,7 @@ PLOCALES="cs de en es fr it nl pt ru uk"
PLOCALE_BACKUP="en"
LUA_COMPAT=( lua5-1 luajit )
-inherit cmake lua-single l10n
+inherit cmake lua-single plocale
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://github.com/instead-hub/${PN}.git"
@@ -61,16 +61,16 @@ DEPEND="${COMMON_DEPEND}"
DOCS=( AUTHORS ChangeLog README.md )
src_prepare() {
- l10n_find_plocales_changes "${S}/lang" "" ".ini"
+ plocale_find_changes "${S}/lang" "" ".ini"
rm_loc() { rm "lang/$1.ini" || die; }
- l10n_for_each_disabled_locale_do rm_loc
+ plocale_for_each_disabled_locale rm_loc
# The docs dir contains some code to build pdf out of the Markdown docs, but it requires some
# weird util called multimarkdown, so we will just install the md's themselfs.
if use doc; then
EXTRA_DOCS=()
- for l in $(l10n_get_locales) ${PLOCALE_BACKUP}; do
+ for l in $(plocale_get_locales) ${PLOCALE_BACKUP}; do
for d in "docs/modules-$l.md" "docs/stead3-$l.md"; do
if [[ -f "$d" ]]; then
EXTRA_DOCS=( "${EXTRA_DOCS[@]}" "$d" )
diff --git a/games-engines/instead/instead-9999.ebuild b/games-engines/instead/instead-9999.ebuild
index f25d0ad53..fd8a67314 100644
--- a/games-engines/instead/instead-9999.ebuild
+++ b/games-engines/instead/instead-9999.ebuild
@@ -7,7 +7,7 @@ PLOCALES="cs de en es fr it nl pt ru uk"
PLOCALE_BACKUP="en"
LUA_COMPAT=( lua5-1 luajit )
-inherit cmake lua-single l10n
+inherit cmake lua-single plocale
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://github.com/instead-hub/${PN}.git"
@@ -61,16 +61,16 @@ DEPEND="${COMMON_DEPEND}"
DOCS=( AUTHORS ChangeLog README.md )
src_prepare() {
- l10n_find_plocales_changes "${S}/lang" "" ".ini"
+ plocale_find_changes "${S}/lang" "" ".ini"
rm_loc() { rm "lang/$1.ini" || die; }
- l10n_for_each_disabled_locale_do rm_loc
+ plocale_for_each_disabled_locale rm_loc
# The docs dir contains some code to build pdf out of the Markdown docs, but it requires some
# weird util called multimarkdown, so we will just install the md's themselfs.
if use doc; then
EXTRA_DOCS=()
- for l in $(l10n_get_locales) ${PLOCALE_BACKUP}; do
+ for l in $(plocale_get_locales) ${PLOCALE_BACKUP}; do
for d in "docs/modules-$l.md" "docs/stead3-$l.md"; do
if [[ -f "$d" ]]; then
EXTRA_DOCS=( "${EXTRA_DOCS[@]}" "$d" )