aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfgang E. Sanyer <ezzieyguywuf@gmail.com>2023-06-06 14:38:32 -0400
committerWolfgang E. Sanyer <ezzieyguywuf@gmail.com>2023-06-06 15:18:26 -0400
commitb8b95bb22462a5114a768b8d4591571bd30377cb (patch)
tree1d7d9ea1ee1a4a5eac51a7c7b45488a394453f28 /games-util
parentapp-text/OCRmyPDF: add 14.2.1 (diff)
downloadguru-b8b95bb22462a5114a768b8d4591571bd30377cb.tar.gz
guru-b8b95bb22462a5114a768b8d4591571bd30377cb.tar.bz2
guru-b8b95bb22462a5114a768b8d4591571bd30377cb.zip
games-util/dwarf-therapist: Bump to 41.2.5
This may be the last version of dwarf-therapist, since it seems like dwarf-fortress is no longer released for linux 😭 See http://www.bay12forums.com/smf/index.php?topic=168411.msg7628208#msg7628208 Signed-off-by: Wolfgang E. Sanyer <ezzieyguywuf@gmail.com>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/dwarf-therapist/Manifest1
-rw-r--r--games-util/dwarf-therapist/dwarf-therapist-41.2.5.ebuild54
-rw-r--r--games-util/dwarf-therapist/metadata.xml3
3 files changed, 58 insertions, 0 deletions
diff --git a/games-util/dwarf-therapist/Manifest b/games-util/dwarf-therapist/Manifest
index 4e6c63d3d4..2dd141b3b5 100644
--- a/games-util/dwarf-therapist/Manifest
+++ b/games-util/dwarf-therapist/Manifest
@@ -1 +1,2 @@
DIST Dwarf-Therapist-41.2.2.tar.gz 1126446 BLAKE2B 44b84661892a50b225c5b69b6196e8397359d073bc9c268713fe93a35852370cfcfcc76df1c52aad814ceb46a74b6a9a7b3bd37bfc5cfec1eb2273b148b3cdb1 SHA512 0235c809be389743fb8205bf43770215efe72c4a178c854b14d1d9ea3a12213abaf58e2832d4c2bcf071d68216a4beff513c7e22712de996c0b6e9024c3010c2
+DIST Dwarf-Therapist-41.2.5.tar.gz 1125524 BLAKE2B a545bac1a87aac09adb22d1863f783389bb3924464e706da534a8b24a1aaadf91e5d10b8b4fe366b7f97b78a7ffec16107bb3ff0719843dfd12e71625c50ade7 SHA512 676c5ef18ff6311ff09beaf59144ac568bf4cf3034c1a9bac65c355029a9718c14bf90a0b6c0f2b357afa95c66a6ab546c0d91fe89cf67987c4e4f432c2177e1
diff --git a/games-util/dwarf-therapist/dwarf-therapist-41.2.5.ebuild b/games-util/dwarf-therapist/dwarf-therapist-41.2.5.ebuild
new file mode 100644
index 0000000000..83f5c802d5
--- /dev/null
+++ b/games-util/dwarf-therapist/dwarf-therapist-41.2.5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake desktop xdg-utils
+
+MY_PN="Dwarf-Therapist"
+MY_PV="v${PV}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="For managing dwarves in Dwarf Fortress"
+HOMEPAGE="https://github.com/Dwarf-Therapist/Dwarf-Therapist"
+SRC_URI="https://github.com/Dwarf-Therapist/${MY_PN}/archive/refs/tags/${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="
+ dev-qt/qtconcurrent:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtwidgets:5
+"
+src_install() {
+ # Install some sort of documentation
+ dodoc README.rst
+
+ # Add the desktop file
+ domenu dist/xdg/applications/dwarftherapist.desktop
+
+ # install icons
+ insinto /usr/share/
+ doins -r dist/xdg/icons
+
+ # install memory layout files for dwarf-fortress versions
+ insinto /usr/share/dwarftherapist/memory_layouts
+ doins -r share/memory_layouts/linux
+
+ # and of course, the binary
+ newbin "${BUILD_DIR}/dwarftherapist" dwarf-therapist
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
diff --git a/games-util/dwarf-therapist/metadata.xml b/games-util/dwarf-therapist/metadata.xml
index 9924b09ad2..767c3433a7 100644
--- a/games-util/dwarf-therapist/metadata.xml
+++ b/games-util/dwarf-therapist/metadata.xml
@@ -5,4 +5,7 @@
<email>ezzieyguywuf@gmail.com</email>
<name>Wolfgang E. Sanyer</name>
</maintainer>
+ <upstream>
+ <remote-id type="github">Dwarf-Therapist/Dwarf-Therapist</remote-id>
+ </upstream>
</pkgmetadata>