aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKostadin Shishmanov <kocelfc@tutanota.com>2023-06-25 21:35:08 +0300
committerKostadin Shishmanov <kocelfc@tutanota.com>2023-06-25 21:35:08 +0300
commitc6ba919bbe9fc371369d65dce906290ac9019cbf (patch)
tree3ab09024dbe87827afd6c672a58a5705f8e059df /media-video
parentnet-wireless/rtl8821ce: Migrate to linux-mod-r1.eclass (diff)
downloadguru-c6ba919bbe9fc371369d65dce906290ac9019cbf.tar.gz
guru-c6ba919bbe9fc371369d65dce906290ac9019cbf.tar.bz2
guru-c6ba919bbe9fc371369d65dce906290ac9019cbf.zip
media-video/obs-vaapi: add 0.3.1
Signed-off-by: Kostadin Shishmanov <kocelfc@tutanota.com>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/obs-vaapi/Manifest1
-rw-r--r--media-video/obs-vaapi/obs-vaapi-0.3.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/media-video/obs-vaapi/Manifest b/media-video/obs-vaapi/Manifest
index 1896710fe5..fa73864e4e 100644
--- a/media-video/obs-vaapi/Manifest
+++ b/media-video/obs-vaapi/Manifest
@@ -1 +1,2 @@
DIST obs-vaapi-0.2.0.tar.gz 14798 BLAKE2B 7ce063193be6ecf75e36836c4540066b27be513e54bdd3299c719b21301448e948561cc5e778ef36df8cb0380e6db24ec7e5a259bdbb18d3877eaeeb977ca36b SHA512 4274ad96c599efc415145853b812f34b0ae921d54b2661d4d383f8346835e6848ae3eed2f0547939fd229341a4b0a3cd47145a4796fa41d9c3639ff92ae398c3
+DIST obs-vaapi-0.3.1.tar.gz 15017 BLAKE2B cc537616b0cfcb9ebaa10565f5e5fa408b25f6c94eb5c878beddf21554db77356a843b5489ed85eeb04b24d59de463ef81215199665c947607905cd232f6b90a SHA512 9d41bd95ef4a8ce3bd7e24ea313bb185fc1a5a1b1adf82f2d69099ba366b4a13096264e716d4a87580eebaf3e54cb0953a15e104a7c3963ba25bdf04ef6b4db4
diff --git a/media-video/obs-vaapi/obs-vaapi-0.3.1.ebuild b/media-video/obs-vaapi/obs-vaapi-0.3.1.ebuild
new file mode 100644
index 0000000000..339a16c636
--- /dev/null
+++ b/media-video/obs-vaapi/obs-vaapi-0.3.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="OBS Studio VAAPI support via GStreamer"
+HOMEPAGE="https://github.com/fzwoch/obs-vaapi"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/fzwoch/obs-vaapi"
+else
+ SRC_URI="https://github.com/fzwoch/obs-vaapi/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="video_cards_amdgpu video_cards_intel"
+RDEPEND=">=media-libs/gst-plugins-bad-1.22.3-r3[vaapi]
+ media-video/obs-studio
+ video_cards_amdgpu? ( media-libs/mesa[vaapi,video_cards_radeonsi] )
+ video_cards_intel? ( media-libs/libva-intel-media-driver )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local emesonargs+=(
+ --libdir=/usr/$(get_libdir)/obs-plugins
+ )
+ meson_src_configure
+}