aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2020-04-13 11:35:54 +0200
committerKurt Kanzenbach <kurt@kmk-computers.de>2020-04-13 11:42:56 +0200
commit2100af6a7b616d536a8e0cba6f5310c1bb55e414 (patch)
tree58f3347de8e6157c7d82ffd0c1c95fef554a473c /net-dialup
parentx11-libs/gtk-fortran: Add NO_BUILD_HL cmake option. Disable build gtkf-sketcher (diff)
downloadguru-2100af6a7b616d536a8e0cba6f5310c1bb55e414.tar.gz
guru-2100af6a7b616d536a8e0cba6f5310c1bb55e414.tar.bz2
guru-2100af6a7b616d536a8e0cba6f5310c1bb55e414.zip
net-dialup/tio: Simple TTY terminal application (new package)
"tio" is a simple TTY terminal application which features a straightforward commandline interface to easily connect to TTY devices for basic input/output. Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de>
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/tio/Manifest1
-rw-r--r--net-dialup/tio/metadata.xml13
-rw-r--r--net-dialup/tio/tio-1.32.ebuild18
3 files changed, 32 insertions, 0 deletions
diff --git a/net-dialup/tio/Manifest b/net-dialup/tio/Manifest
new file mode 100644
index 000000000..e4ef49976
--- /dev/null
+++ b/net-dialup/tio/Manifest
@@ -0,0 +1 @@
+DIST tio-1.32.tar.xz 88976 BLAKE2B d9f97e0c37326d5db2c6a7d681569738aced6ba45dc60d320bf5dc00db1d77b72474309d0b790ba6af1360cde145cda04ddbc2ba58f69cef1e2331906d04cc89 SHA512 6ec216ea8e60fe8fb09e3bc378d8178f0d27789ba876e5a763c1eeef7de064831143270e644e64658d3b9acaf3c1b406f1e3331acc4c8bee91fd56851b99941f
diff --git a/net-dialup/tio/metadata.xml b/net-dialup/tio/metadata.xml
new file mode 100644
index 000000000..10c5b3e7a
--- /dev/null
+++ b/net-dialup/tio/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>kurt@kmk-computers.de</email>
+ <name>Kurt Kanzenbach</name>
+ </maintainer>
+ <longdescription>
+ "tio" is a simple TTY terminal application which features a straightforward
+ commandline interface to easily connect to TTY devices for basic
+ input/output.
+ </longdescription>
+</pkgmetadata>
diff --git a/net-dialup/tio/tio-1.32.ebuild b/net-dialup/tio/tio-1.32.ebuild
new file mode 100644
index 000000000..8fae4c4f5
--- /dev/null
+++ b/net-dialup/tio/tio-1.32.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools bash-completion-r1
+
+DESCRIPTION="Simple TTY terminal application"
+HOMEPAGE="https://tio.github.io/"
+SRC_URI="https://github.com/tio/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+
+src_configure() {
+ econf --with-bash-completion-dir="$(get_bashcompdir)"
+}