aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2022-03-26 10:20:24 +0100
committerKurt Kanzenbach <kurt@kmk-computers.de>2022-03-26 10:30:46 +0100
commitadc5ee3c97f40a15bcdfc1d394bdaf3f3d85490a (patch)
treea9b58fe55758594d4950eaddded850714309555e /net-dialup
parentsys-cluster/scr: also link yogrt for serial library (diff)
downloadguru-adc5ee3c97f40a15bcdfc1d394bdaf3f3d85490a.tar.gz
guru-adc5ee3c97f40a15bcdfc1d394bdaf3f3d85490a.tar.bz2
guru-adc5ee3c97f40a15bcdfc1d394bdaf3f3d85490a.zip
net-dialup/tio: Bump version to v1.36
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de>
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/tio/Manifest1
-rw-r--r--net-dialup/tio/tio-1.36.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/net-dialup/tio/Manifest b/net-dialup/tio/Manifest
index dac6f17ee..fe7a6dc3c 100644
--- a/net-dialup/tio/Manifest
+++ b/net-dialup/tio/Manifest
@@ -1 +1,2 @@
DIST tio-1.35.tar.xz 1413192 BLAKE2B 04d1d237187c854d767963d3dc80b572fbdf58f3668861a7b704a45664645782e77245cd2c3f9b64e0b829a8b08fb5d1b5c29a2b62e8fc134949752d97f64336 SHA512 e2ca85e189d218be4f61b0e1602e8bca5deaf93affcd2c25e1155bd25e1b31ee2d3b1ff7327225a74f3ad04d56bc5ccc18758c92947c9fb2059ebe8224659961
+DIST tio-1.36.tar.xz 1803668 BLAKE2B b973c3cc344486d78b5634a6929e9b4c9550f5af029c77be70c0f10a1bc4519c4d4b31c3125cfe2a88dbf01d400b3cb74841c06c8831ba677077e8aa57751e00 SHA512 fda643b5ed8f24acfc2b9135cf508acbca1157806de884c152882526688a05e823c7de29196cb94e6bedb025bfda8750d736e07e5b829df784cb7f9042ec214a
diff --git a/net-dialup/tio/tio-1.36.ebuild b/net-dialup/tio/tio-1.36.ebuild
new file mode 100644
index 000000000..aa1af5f4e
--- /dev/null
+++ b/net-dialup/tio/tio-1.36.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson bash-completion-r1
+
+DESCRIPTION="Simple TTY terminal application"
+HOMEPAGE="https://tio.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-libs/inih
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dbashcompletiondir="$(get_bashcompdir)"
+ )
+
+ meson_src_configure
+}