aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com>2022-04-23 13:19:28 -0400
committerPhilippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com>2022-04-23 13:19:28 -0400
commitc64059b5d460b6cb4c5a813fa7789e9d4ed48738 (patch)
treeadbbfb60306a459093cc8f40d43cc6e0471a8e78 /net-mail
parentdev-libs/zlib-google: update Manifest (diff)
downloadguru-c64059b5d460b6cb4c5a813fa7789e9d4ed48738.tar.gz
guru-c64059b5d460b6cb4c5a813fa7789e9d4ed48738.tar.bz2
guru-c64059b5d460b6cb4c5a813fa7789e9d4ed48738.zip
net-mail/dovecot-fts-xapian: add 9999
Signed-off-by: Philippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/dovecot-fts-xapian/dovecot-fts-xapian-9999.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/net-mail/dovecot-fts-xapian/dovecot-fts-xapian-9999.ebuild b/net-mail/dovecot-fts-xapian/dovecot-fts-xapian-9999.ebuild
new file mode 100644
index 000000000..ac1085894
--- /dev/null
+++ b/net-mail/dovecot-fts-xapian/dovecot-fts-xapian-9999.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Dovecot FTS plugin backed by Xapian"
+HOMEPAGE="https://github.com/grosjo/fts-xapian"
+
+if [ "$PV" = 9999 ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/grosjo/fts-xapian/"
+else
+ SRC_URI="https://github.com/grosjo/fts-xapian/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/fts-xapian-${PV}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+IUSE="static-libs"
+
+RDEPEND="
+ dev-libs/icu:=
+ >=dev-libs/xapian-1.4:=
+ net-mail/dovecot:=
+ "
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+if [ "$PV" = 9999 ] ; then
+ BDPEND="${BDEPEND}
+ sys-devel/autoconf
+ sys-devel/autoconf-archive
+ "
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-dovecot="${EPREFIX}/usr/$(get_libdir)/dovecot" \
+ $( use_enable static-libs static )
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}